none
Unable to install azure-cognitiveservices-speech RRS feed

  • Question

  • I am a Product Manager (i.e. not a coder) investigating the speech to text and text to speech services within Azure. I have been trying to get the Quickstart examples working... 

    (e.g. at https://docs.microsoft.com/en-gb/azure/cognitive-services/speech-service/quickstarts/speech-to-text-from-microphone?tabs=dotnet%2Cx-android%2Clinux%2Cjava-runtime&pivots=programming-language-python)

    This page includes the following instruction:

    "If a new version is available, you can update to it with the command pip install --upgrade azure-cognitiveservices-speech."

    However, when I try this command I get the response:

    "ERROR: Could not find a version that satisfies the requirement azure-cognitiveservices-speech (from versions: none)
    ERROR: No matching distribution found for azure-cognitiveservices-speech"

    I get the same response if I try a straight install (i.e. without the --upgrade command.)

    To test if the problem was path related, I tried to install a different cognitive services package using the command:

    "pip install azure-cognitiveservices-language-textanalytics"

    This package installed correctly.

    I tried to install all azure components using the command "pip install azure". This took a while and a large number of packages are now present, but the azure-cognitiveservices-speech package is not among them.

    What am I doing wrong?!

    Thanks for your help

    Nick

    Thursday, November 28, 2019 6:01 PM

All replies

  • Hello Nick,

    Could you please run the command "pip show azure-cognitiveservices-speech" command to check if the package for speech SDK is installed on your machine?

    If it is installed and having issues the best option would be to remove the package using "pip uninstall azure-cognitiveservices-speech" and run install again to see if this solves the issue. 

    I hope this helps you to debug the issue and install the package without any issues.

    -Rohit

    Friday, November 29, 2019 11:02 AM
    Owner
  • Thank you for your response.

    I have tried the 'pip show' command, and the speech SDK is not installed on my machine.

    To double-check I tried to 'pip uninstall' the package, and got the message "WARNING: Skipping azure-cognitiveservices-speech as it is not installed."

    So I tried again to install, with the command 'pip install azure-cognitiveservices-speech' and again got the message

    "ERROR: Could not find a version that satisfies the requirement azure-cognitiveservices-speech (from versions: none)
    ERROR: No matching distribution found for azure-cognitiveservices-speech"
     

    Am I spelling the package name correctly?

    Thanks again

    Nick

    Friday, November 29, 2019 2:51 PM
  • Hi,

    Could you please run with the following command with inclusion of the version.

    pip install azure-cognitiveservices-speech==1.8.0

    Thanks 

    Monday, December 2, 2019 6:12 AM
    Moderator
  • Hello,

    Thank you for the suggestion. I tried the command with version number but still got an error message:

    ERROR: Could not find a version that satisfies the requirement azure-cognitiveservices-speech==1.8.0 (from versions: none)
    ERROR: No matching distribution found for azure-cognitiveservices-speech==1.8.0

    I'm still at a loss here. is there something wrong on my local machine? e.g. a path setting or some other environment variable not set properly?

    Thanks for all your help

    Nick

    Monday, December 2, 2019 8:19 AM
  • Hi,

    Can you please check what is your Python version? 

    Please use 64-bit.

    Thanks


    Monday, December 2, 2019 11:42 AM
    Moderator
  • Hello,

    I have tried this with two versions, 3.7.4 and 3.8.0. These state the following:

    Python 3.7.4 (tags/v3.7.4:e09359112e, Jul  8 2019, 20:34:20) [MSC v.1916 64 bit (AMD64)] on win32

    Python 3.8.0 (tags/v3.8.0:fa919fd, Oct 14 2019, 19:37:50) [MSC v.1916 64 bit (AMD64)] on win32

    My computer is a MS Surface Book II, running Windows 10 Pro as a 64-bit Operating system.

    Thanks

    Nick

    Monday, December 2, 2019 12:09 PM
  • Hi,

    We would recommend to raise a Azure support desk ticket from Help+Support blade from Azure portal.This will help you to share the details securely and work with an engineer who can provide more insights about the issue.

    Thanks


    Tuesday, December 3, 2019 5:57 AM
    Moderator
  • Ok, I will try that.

    Thank you very much for your help so far. I will report back if/when a solution appears.

    Thanks

    Nick

    Tuesday, December 3, 2019 9:46 AM
  • Hello,

    I think I have made progress!

    I uninstalled both versions of Python and cleared all references to it from my machine. Then selected and installed Python 3.7.5 (64-bit) from the installer downloaded from this page:

    https://www.python.org/downloads/windows/

    After install, I tried the command 'pip' on its own and this time got some very different error messages:

    Traceback (most recent call last):
      File "c:\users\nickc\appdata\local\programs\python\python37\lib\runpy.py", line 193, in _run_module_as_main
        "__main__", mod_spec)
      File "c:\users\nickc\appdata\local\programs\python\python37\lib\runpy.py", line 85, in _run_code
        exec(code, run_globals)
      File "C:\Users\NickC\AppData\Local\Programs\Python\Python37\Scripts\pip.exe\__main__.py", line 9, in <module>
    TypeError: 'module' object is not callable

    This suggested to me that the re-install had not been completely successful. So I uninstalled and checked for install instructions elsewhere. I came up with this page:

    https://github.com/BurntSushi/nfldb/wiki/Python-&-pip-Windows-installation

    This page gave me a manual, step by step approach to installing Python and Pip and setting my path correctly.

    Now I tried the "pip install azure-cognitiveservices-speech==1.8.0" command, and this time it reported successful install. Hurrah!

    Now I can begin coding... Thanks for your help!

    Nick

    Wednesday, December 4, 2019 4:56 PM