none
Can we add nodes to standard EDIFACT-D93A-Orders.xsd schema RRS feed

  • General discussion

  • Hi,

    can I add UNB nodes to standard EDIFACT-D93A-Orders schema. if it is possible please give us a sample.

    Regards

    kishore.

     


    Monday, October 31, 2011 8:17 AM

All replies

  • You cannot and should not. The UNB segment is part of an EDIFACT envelope and has nothing to do with the actual message. The schema is only representing the message. Use Party/Agreement setup to configure how each trading partners UNB segment should look like.

     

    Morten la Cour

    Monday, October 31, 2011 8:50 AM
  • Hi,

    Thanks for your valueble reply,

     

    how to configure party/agreement for EDIFACT-D93A-Orders. please give us a sample for that. that is very needful for me.

     

    Regards,

    kishore.

    Monday, October 31, 2011 8:55 AM
  • Are you using Biz 2010?`

     

    la Cour

    Monday, October 31, 2011 8:58 AM
  • yes I am using Biz2010
    Monday, October 31, 2011 9:02 AM
  • Create two parties (You and the TP you want to send the EDIFACT document to)

    -Right-click the TP_Profile and choose New-Agreement

    -In second party choose yourself

    -In protocol choose EDIFACT

    Now two new tabs will appear (You->TP and TP->You)

    -Choose You->TP (you will be sending to TP)

    -Under Interchange Settings/Identifiers set up your UNB properties.

    -Under Interchange Setttings/Send Ports choose the send port you want to use to send to the TP.

    -Click OK

    -Make sure that your Send Port has EDISend as pipeline (reference the EDI application if you havn't already done that), and that you are sending an EDIFACT XML document through it.

    Restart the BizTalk host used in the send port and try it out.

     

    Morten la Cour

     

    Monday, October 31, 2011 9:08 AM
  • Hi,

    what is the use of party? without party we can't send the files to particular location?

     

    Regards,

    kishore.

     

    Monday, October 31, 2011 9:36 AM
  • Yes, but without parties all trading partners will be given the default UNA/UNB properties, and since they always vary from TP to TP, we need to set this up in parties.

     

    Morten la Cour

    Monday, October 31, 2011 9:40 AM
  • Hi,

     

    Thank you for valuble reply

     

    after creating the parties showing following error

     

    A message received by adapter "FILE" on receive location "EDI_Receive_Location" with URI "D:\NORSKSynergi\ImportEDIOrdersToAxapta\In\*.*" is suspended.
     Error details: An output message of the component "Unknown " in receive pipeline "Microsoft.BizTalk.Edi.DefaultPipelines.EdiReceive, Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" is suspended due to the following error:
         Error encountered during parsing. The Edifact transaction set with id '6OWNT' contained in interchange (without group) with id '4ORLD', with sender id '7080000081585', receiver id '7080000985678' is being suspended with following errors:
    Error: 1 (Field level error)
        SegmentID: BGM
        Position in TS: 2
        Data Element ID: BGM04
        Position in Segment: 4
        Data Value: AE
        12: Invalid value in data element

    Error: 2 (Field level error)
        SegmentID: QTY
        Position in TS: 21
        Data Element ID: C18602
        Position in Segment: 2
        Position in Field: 2
        Data Value: 70.00
        37: Invalid character(s) found in data element

    Error: 3 (Field level error)
        SegmentID: QTY
        Position in TS: 26
        Data Element ID: C18602
        Position in Segment: 2
        Position in Field: 2
        Data Value: 36.00
        37: Invalid character(s) found in data element

    Error: 4 (Field level error)
        SegmentID: QTY
        Position in TS: 31
        Data Element ID: C18602
        Position in Segment: 2
        Position in Field: 2
        Data Value: 180.00
        37: Invalid character(s) found in data element

    Error: 5 (Field level error)
        SegmentID: QTY
        Position in TS: 36
        Data Element ID: C18602
        Position in Segment: 2
        Position in Field: 2
        Data Value: 60.00
        37: Invalid character(s) found in data element

    Error: 6 (Field level error)
        SegmentID: QTY
        Position in TS: 41
        Data Element ID: C18602
        Position in Segment: 2
        Position in Field: 2
        Data Value: 36.00
        37: Invalid character(s) found in data element

    Error: 7 (Field level error)
        SegmentID: QTY
        Position in TS: 46
        Data Element ID: C18602
        Position in Segment: 2
        Position in Field: 2
        Data Value: 36.00
        37: Invalid character(s) found in data element

    .
     The sequence number of the suspended message is 1. 
     MessageId:  {39C11C14-EE72-4B6C-8F3D-5C2FA364B89E}
     InstanceID: {ED684040-628B-455D-8D5C-B9BEF8A9F948}

     

    Regards,

    kishore

    Monday, October 31, 2011 11:12 AM
  • For the decimal values this is because it is not allowed in EDIFACT to have trailing zeros. This can, however, be ignored by setting the following in your agreement:

    Transaction Set Settings->Validation->Allow leading and trailing zeros....

    (Remember to restart your host-instance, since all party properties are cached).

    As for the BGM segment, AE (ebit advice for each transaction) should be a valid value in BGM04. Have you used the standard EFACT_ORDERS_D93A Schema and not tampered with it, or is there a space before or after the AE that I cannot see?

    Morten la Cour


    • Edited by la Cour Monday, October 31, 2011 11:20 AM
    Monday, October 31, 2011 11:19 AM
  • Hi,

     

    I will checked this property Transaction Set Settings->Validation->Allow leading and trailing zeros..

    still same error is coming

     

    Regards,

    kishore.

    Monday, October 31, 2011 11:34 AM
  • I don't understand this. Your error indicates that this is when receiving EDIFACT and not sending as I described earlier?

    If you are receiving not sending, then you need to set up identifiers in (TP->You) and Set the zero validation in that flow instead.

    Morten la Cour

    Monday, October 31, 2011 11:42 AM
  • Hi,

     

    Thank you so much, my problem is resolved when i check Transaction Set Settings->Validation->Allow leading and trailing zeros.. but still facing problem with BGM tag.

     

     

     

    Regards,

    kishore.

    Monday, October 31, 2011 11:50 AM
  • Well are you using a standard EDIFACT ORDERS D93A schema with no tampering? And is the value in the EDIFACT document just EA or are there any spaces etc.?


    Morten la Cour

    Monday, October 31, 2011 11:52 AM
  • Hi,

    I have used the standard EFACT_ORDERS_D93A. But BGM showing above error.

     

    Regards,

    kishore.

     

    Monday, October 31, 2011 11:52 AM
  • Sorry AE is NOT allowed in 93, it was added in a later version!

    If you can't tell your trading partner that this is infact invalid edi, you can do the following:

     

    - Open your schema, expand the BGM segment and click on BGM04.

    - Under properties choose Enumeration and add "AE".

    Redeploy and restart host instance.

    Morten la Cour

     

     



    • Edited by la Cour Tuesday, November 1, 2011 3:51 PM
    Monday, October 31, 2011 11:58 AM
  •  

     

    Hi,

     

    Monday, October 31, 2011 12:07 PM
  • Hi,

     

    I am using above Standard EDIFACT_D93A_ORDERS map to my destination schema which is according to my requirement. so if you require .cs file of this schema also, i can provide u

     

    Please help.

     

    Regards,

    kishore.

    Monday, October 31, 2011 12:08 PM
  • First of all I asked for the EDIFACT document not a map!! :-) But just add AE to the enumeration like I discribed in my previous post.

     

    Morten la Cour

    Monday, October 31, 2011 12:10 PM
  • Hi,

    Great job Morten la Cour !!!!!!. It worked when i added  AE to enumuration collection.

     

    Thanks a lot :).

     

    Regards,

    kishore.

    Monday, October 31, 2011 12:35 PM
  • Please mark my answers as answer then

     

    Morten la Cour

    Monday, October 31, 2011 12:35 PM
  • I unable to see mark as answer. how to do that?
    Thursday, November 3, 2011 8:10 AM
  • I think it is because this a discussion and not a question? Not sure?

    Morten la Cour

    Thursday, November 3, 2011 9:38 AM
  • yes this is not a question, sorry for the late reply

    Thursday, November 3, 2011 10:02 AM