locked
Login Fails after SQL Server 2005 SP3 Upgrade RRS feed

  • Question

  • I upgraded one of our SQL Server 2005 servers to SP3 and after the upgrade completed successfully I had a Windows Account with sysadmin rights that couldn't login.  The Error was 18456, Serverity 14, State 11.  The BULTIN\Administratrs accounts worked fine, it was just this account.  To work around the issue I added it to the account to the local Administrators group and that fixed the problem but I've got other SQL Servers I'm going to be applying SP3 to and would like to know if this is an isolated problem or something that SP3 changed that I need to prepare for or do something after the upgrade completes to make the ID work again.

    This case it was a 32Bit Enterprise Edition installation on Windows Server 2003 Standard Edition.

    Thanks for you assistance.
    • Edited by JohnFerrin Tuesday, September 29, 2009 4:34 PM Added another line
    Tuesday, September 29, 2009 4:33 PM

Answers

  • Hi John,

    Usually it does not happen after you have installed SP3, I think this problem with permissions, you could try to delete this Windows account from Logins and them add it to Logins again to see if it works.

    Have a nice day, thanks!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, October 1, 2009 9:54 AM

All replies

  • Hi John,

    I havent seen such problem in my environment where i have upgraded a dozen of servers.
    The error 18456, Serverity 14, State 11 states that these logins are "Valid login but server access failure" and that's the reason you were able to login once the permission was given explicitly.


    Thanks, Leks
    Wednesday, September 30, 2009 10:14 PM
  • Hi John,

    Usually it does not happen after you have installed SP3, I think this problem with permissions, you could try to delete this Windows account from Logins and them add it to Logins again to see if it works.

    Have a nice day, thanks!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, October 1, 2009 9:54 AM
  • Thanks for responding ChunSong and Lekss.  I've got a couple to upgrade this weekend and if I run into the problem I'll try your suggestion ChunSong.
    Tuesday, October 6, 2009 5:44 PM