none
Disabling Windows Error Recovery on startup RRS feed

  • Question

  • How can I disable the Windows Error Recovery screen which appears during boot if Windows was not shut down properly?

    I use a custom shell to launch the only program that runs on Embedded 7 and it does not matter if user plugs the power cord out without shutting down the machine properly.  Also it makes no sense to go into Safe Mode ever in this kind of embedded scenario.

    If I write-protect Windows files or partition (with write filters) does that prevent for the error recovery screen to appear?

    Regards,
    Kim
    Wednesday, October 7, 2009 11:34 AM

Answers

  • For CTP , please run the following command to disable recovery screen due to shutdown failures (which includes intentionally yanking the power cord)

    bcdedit /set {current} bootstatuspolicy ignoreallfailures
    In the next public version of WES 2011, this will done automatically if EWF or FBWF are included in the image. There'll also be an SMI setting to fine tune this behavior.

    Thanks
    Srikanth
    Srikanth Kamath [MSFT]
    Wednesday, October 7, 2009 3:20 PM

All replies

  • For CTP , please run the following command to disable recovery screen due to shutdown failures (which includes intentionally yanking the power cord)

    bcdedit /set {current} bootstatuspolicy ignoreallfailures
    In the next public version of WES 2011, this will done automatically if EWF or FBWF are included in the image. There'll also be an SMI setting to fine tune this behavior.

    Thanks
    Srikanth
    Srikanth Kamath [MSFT]
    Wednesday, October 7, 2009 3:20 PM
  • Thanks, that's what I was looking for!

    Regards,
    Kim
    Thursday, October 8, 2009 6:51 AM
  • Srikanth:

    Has this SMI setting been implemented in Windows Embedded Standard 7? If so, what is the SMI setting please. I am NOT using EWF nor FBWF.

    Thank  you,

    Jay Steeby

    Monday, June 14, 2010 7:58 PM
  • Yes. Both EWF and FBWF have a SMI setting named BootStatusPolicy (with default set to IgnoreAllFailures). Since you are not using either of them you will have to run the command manually. (perhaps in the RunOnce section)
    Srikanth Kamath [MSFT] - This posting is provided "As Is" with no warranties, and confers no rights.
    Tuesday, June 15, 2010 3:16 AM
  • I need to disable the Windows 7 Error recovery screen (or greatly shorten its display time).

    Using an elevated command prompt, I have tried: bcdedit /set {current} bootstatuspolicy ignoreallfailures

    But get the error "The integer data is not valid as specified."

    What am I doing wrong?

    Friday, June 25, 2010 2:51 PM
  • bcdedit /set {current} bootstatuspolicy ignoreallfailures

    Are you sure you are using the above command line verbatim ? I used it verbatim and it works without problems. I can repro your error if I make a type such as 

    bcdedit /set {current} bootstatuspolicy ignore allfailures

    Could you please type it out (not copy/paste) verbatim to verify?

     


    Srikanth Kamath [MSFT] - This posting is provided "As Is" with no warranties, and confers no rights.
    • Proposed as answer by jduffy Friday, January 2, 2015 4:03 PM
    Friday, June 25, 2010 10:35 PM
  • My bad...typed the command correctly this time and it worked flawlessly - thank you. Now, is there a command to that will undo this setting?
    Tuesday, July 6, 2010 2:20 PM
  • :) yes of course

    bcdedit /set {current} bootstatuspolicy ignore displayallfailures


    Srikanth Kamath [MSFT] - This posting is provided "As Is" with no warranties, and confers no rights.
    Tuesday, July 6, 2010 4:07 PM
  • Hi,

     

    I used this string: bcdedit /set {default} bootstatuspolicy ignoreallfailures (or displayallfailures) and it worked.

    But can I ask you, if all failures are ignored and Windows 7 Home Premium 64 bit will not start at all for some reason or other, what can I expect to see?

    Will there be at least an opportunity to enter the displayallfailures in a DOS prompt ro something?

     

    Thanks,

    Selvan

    Friday, August 13, 2010 8:18 PM
  • Hi

    i used this command

    bcdedit /set {current} bootstatuspolicy ignoreallfailures

    and when i check the status using bcdedit /enum it shows that all failures would be ignored but when i power off/on pc by plugging out the power cable a menu appeared with safe mode and normal startup (being the default) - with 30 second time out

    i selected normail startup and when the windows was booting again unplugged to cut the power and when i plugged back this time i get the boot menu with startup recovery being the default.

    I did this a few times and i always get the same despite the fact that BCD is ignoring all kinds of failures.

    Please help as power shortage in our area is a serious issue with a lot of fluctuation, powering on/off the pc multiple times within a short span of time. As my pc is unattended i want to completely disable windows recovery feature.

    Thanks

    Sunday, February 20, 2011 11:24 AM
  • @purple_vivid:

    Change {current} to {default} and that worked for me with WES7.  Restart Windows normally, once.  Thereafter, my settings worked fine and WES7 started fine (w/o Error Recover) after power was pulled.

    Monday, February 21, 2011 7:44 PM
  • When I type the command into command prompt and I press enter it says that it was completed succesfuly . What do I do after that ? Because I cant even login to get to my desktop . PLEASE HELP !
    Sunday, July 17, 2011 5:35 PM
  • I was working on a windows 7 ultimate clone desktop PC that was running the handy cafe program hence I cannot access the desktop when windows start to disable the ERROR RECOVERY OPTION. This Is what I did. Tap F1 Key as soon as the PC starts (the boot option screen appears). Press F8 for advance boot options. Select Safe Mode and press enter. Type cmd in the Run/Search field (this opens command prompt). You can type bcdedit /? for all commands.

    Now, disabling windows error recovery option on startup. I typed bcdedit /set <current> bootstatuspolicy ignoreallfailures but it cannot find the file current. I then type:

    bcdedit /set bootstatuspolicy ignoreallfailures

    The command was completed successfully. I did a system restart and and windows started successfully with no more annoying error recovery option. Thanks Kamath.

    Peter

    Thursday, September 13, 2012 2:30 PM
  • I typed the command prompt but it came that `the boot configuration data store could not be opened.Acess is denied'. Why?

    Saturday, October 13, 2012 1:52 PM
  • open admin console as administrator.

    Windows Embedded Developer and Scripting Guy //Germany (Preparing a blog about Windows Embedded Standard)

    Saturday, October 13, 2012 9:20 PM
  • open admin console as administrator.

    Windows Embedded Developer and Scripting Guy //Germany (Preparing a blog about Windows Embedded Standard)

    i did it but the same thing is coming.Why?

    Sunday, October 14, 2012 8:27 AM
  • Hello

    I followed this thread http://social.msdn.microsoft.com/Forums/en-US/quebecmisc/thread/12806c89-3592-4748-83dd-5b55eabec5a1 but even after a lot of effort my Windows 7 ALWAYS shows the recovery menu when starting up.

    I have gone thru System repairs, all sorts of BCDEDIT I can think off, and it still always shows the menu.

    What I am doing wrong? Output of my BCDEDIT /ENUM ALL below...

    ---


    Gestor de Arranque do Windows
    -----------------------------
    identificador           {bootmgr}
    device                  partition=\Device\HarddiskVolume1
    description             Windows Boot Manager
    locale                  pt-PT
    inherit                 {globalsettings}
    default                 {current}
    resumeobject            {4ff4c6a5-6d6f-11e2-9f50-98d043e67837}
    displayorder            {current}
    toolsdisplayorder       {memdiag}
    timeout                 0

    Carregador de Arranque do Windows
    ---------------------------------
    identificador           {current}
    device                  partition=C:
    path                    \Windows\system32\winload.exe
    description             Windows 7
    locale                  pt-PT
    inherit                 {bootloadersettings}
    recoverysequence        {4ff4c6a7-6d6f-11e2-9f50-98d043e67837}
    recoveryenabled         No
    osdevice                partition=C:
    systemroot              \Windows
    resumeobject            {4ff4c6a5-6d6f-11e2-9f50-98d043e67837}
    nx                      OptIn
    bootstatuspolicy        IgnoreAllFailures

    Carregador de Arranque do Windows
    ---------------------------------
    identificador           {4ff4c6a7-6d6f-11e2-9f50-98d043e67837}
    device                  ramdisk=[C:]\Recovery\4ff4c6a7-6d6f-11e2-9f50-98d043e67837\Winre.wim,{4ff4c6a8-6d6f-11e2-9f50-98d043e67837}
    path                    \windows\system32\winload.exe
    description             Windows Recovery Environment
    inherit                 {bootloadersettings}
    osdevice                ramdisk=[C:]\Recovery\4ff4c6a7-6d6f-11e2-9f50-98d043e67837\Winre.wim,{4ff4c6a8-6d6f-11e2-9f50-98d043e67837}
    systemroot              \windows
    nx                      OptIn
    winpe                   Yes

    Sunday, February 3, 2013 10:21 AM
  • What is the best way to populate the command throughout the entire company?  GPO? Logon Scipt?

    
    Wednesday, February 13, 2013 7:32 PM
  • I second that. Is there a way to get the same effect as bcdedit /set {current} bootstatuspolicy ignoreallfailures via GP?
    Thursday, October 3, 2013 2:38 PM
  • Hi,

    i have the same issue and i do the commands above. After a restart the system dosn't boot and shows an error :-(

    "Windows Boot Manager"
    ...
    File: \Windows\system32\config\system
    Status: 0xc000041c
    Info: Windows konnte nicht geladen werden, da die Systemregistrierung nicht vorhanden oder beschädigt ist

    After i rename the file \Windows\system32\config\system from \Windows\system32\config\RegBack\system i get the next error 0xc0000098 

    /windows/system32/ntoskrnl.exe is missing or is corrupt

    What can i do now?

    regards,
    Lars

    Monday, April 13, 2015 7:47 AM
  • is there a way that you can ran this via Task Sequence 

    C:\Windows\System32\bcdedit.exe /set {default} recoveryenabled No
    C:\Windows\System32\bcdedit.exe /set {default} bootstatuspolicy ignoreallfailures

    Thursday, June 23, 2016 6:55 PM
  • Why a task sequence?

    If it needs to be set it should be set once and done.


    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Thursday, June 23, 2016 8:59 PM
    Moderator