none
VSTO Add-in fails to Load when Word 2010 is Loaded from a template RRS feed

  • Question

  • I have a VS 2010 created Add-In for Word 2010 that works as expected and loads as expected except when Word is loaded from a template. When Word is run to load from a template (for data merging etc) the Add-in is "available" but only by going to COM Add-Ins (either from the Developer Tab - which I would rather the users did not need to activate - or from the Options - Add-ins area)

    Sadly this make the Add-in appear a little clunky! How do I make sure that it loads when Word loads via a Template?

    I have replicated this behaviour on Windows 7 and Windows XP, and on the development machine (windows 7 64 bit)


    dotNET and SQL Developer. Gold-Vision Partner
    Friday, March 18, 2011 10:31 AM

Answers

  • Got to the bottom of it - back to basics again:)

    My code for ThisAddIn_Startup had an error that did not show up when testing until I reduced to a minimum code set

     

    Thanks anyway

     

     


    dotNET and SQL Developer. Gold-Vision Partner
    • Marked as answer by Bessie Zhao Thursday, March 24, 2011 9:30 AM
    Monday, March 21, 2011 4:19 PM

All replies

  • Hello Richard,

    Thanks for posting. For this issue, we could try to troubleshoot this issue by using the following blog: http://blogs.msdn.com/b/haahmadi/archive/2010/05/26/my-vsto-add-in-does-not-load.aspx. There might be more information we could use for further research.

    From what you said, I suggest you could create a very simple add-in or put the code into try and catch block. Please see if this issue also happens.

    Also please refer to this MSDN blog for more information about how to debug add-in: http://msdn.microsoft.com/en-us/library/ms269003.aspx.

    If the information above does not help you, would you please tell me more information about loading word 2010 from a template? By double-clicking an Word template file (.dotx), it will open an new document (.docx) file. Do you mean this way? If not, just feel free to correct me.

    We are looking forward to your reply. Have a nice day.


    Bessie Zhao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, March 21, 2011 3:41 AM
  • Got to the bottom of it - back to basics again:)

    My code for ThisAddIn_Startup had an error that did not show up when testing until I reduced to a minimum code set

     

    Thanks anyway

     

     


    dotNET and SQL Developer. Gold-Vision Partner
    • Marked as answer by Bessie Zhao Thursday, March 24, 2011 9:30 AM
    Monday, March 21, 2011 4:19 PM
  • Hello again Richard,

    Glad to know that you have found the cause of this issue.  So I will write to check the status of the issue on your side. If you have any questions or concerns, please feel free to let me know. I will be more than happy to be of assistance.

    Have a nice day.


    Bessie Zhao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, March 22, 2011 5:48 AM