locked
Problem using [Me] filter on list RRS feed

  • Question

  • Hi

    I want to create a list view that shows only the items created by the current user (Sharepoint 2007). To do that i created a view and on filter options I selected Created By as the column, and [Me] as the filter value (equals). But for some unknowed reason it simple doesn't work, nothing shows up.

    I already done this on Sharepoint 2010, and worked like a charm. But on 2007 dunno why it doesn't work. Google doesn't seem to have much to say.

    Any ideia what it could be?

     

    Thanks

    Friday, October 7, 2011 3:24 PM

All replies

  • Is the account you logged is a System account?  Please refer to the following post

    http://social.technet.microsoft.com/Forums/eu/sharepointadmin/thread/c0bd66ed-f9c4-4395-9fed-30b75e6975cb


    --Cheers
    • Edited by Prasath C Friday, October 7, 2011 4:13 PM
    Friday, October 7, 2011 4:12 PM
  • Nope, it's not a system account.
    Friday, October 7, 2011 5:02 PM
  • Hi Ricardo,

    I’m sorry that I cannot reproduce your issue, the filter in my view works well, as I set the filter Created By is equal to [Me].

    In order to find the reasons of this issue, please modify the view to show the Created By column, compare the Created By value to the user login credentials, to see whether they are same. Also, check whether you have other filters that affect the result.

    Thanks,
    Qiao

    Monday, October 10, 2011 4:48 AM
    Moderator
  • Hi, I already tried that, is there any list or site definition option that could affect the filters? Atm it's my best guess, since I can't find anything wrong with the filter.
    Monday, October 10, 2011 9:29 AM
  • Also.... I tried to compare with the fullname (hardcoded) instead of [Me] and it works :S. Filtering using the webpart on designer also works. It seems that [Me] isn't getting the current user :S
    Monday, October 10, 2011 11:43 AM
  • Hi, 

    I had the same problem. 

    I figured out that I can't use [Me], I must use the translated word. In my case it is called [Ich].

    Can you try it? 

    I recieved the corret names with a calculated column.

    You must create a calculated colum with the formular =[Me].

    After that you get the error messages with the correct keywords.

    Wednesday, September 24, 2014 10:26 AM