none
VS Community 2015 Licence trouble

    Question

  • I used a long time vs express 2013, but after installitiong unity, it does not work anymore. With unity installed vs community 2015 with 30 day trial license. Now license is over and i cant update it. I surfed a lot ot threads with same problem and all solutions were worthless:

    1) update/download ie 11 - have it;

    2) control panel - vs community 2015 - repair - done;

    3) enroll for "vs dev essentials" - sign out then sign in - done;

    Many threads from StackOverflow and   https://social.msdn.microsoft.com/Forums/en-US/d2339191-512e-4788-8631-18883397bee4/vs2015-community-we-could-not-download-a-license?

    4) disable firewall and remove all from hosts (my paltry attempts to fix it)

    screen: http://i.imgur.com/ncVxeMy.png

    and sure i cannot create thread with images/links

    Sunday, August 28, 2016 9:10 AM

All replies

  • Hi S0HardCore,

    In my side I could update the license of my VS2015 community successfully. Just like the following screenshot:

    Please refer to the following steps to troubleshoot your issue:

    1). Please run your VS in Administrator which make sure it has enough right.

    2). Make sure your Microsoft account could sign in the Microsoft Home Page successfully. Please click sign in link in the upper right corner of this site. And type your Microsoft account to observer whether log in successfully.

    3). Because when we sign in the Microsoft account in VS, and VS will call IE core to sign in the account. We could delete all cookies of IE and reset it. Please refer to the following steps:

    Delete cookies:

    Open IE->click Tools->Internet options->select General tag->click Delete->Delete

    Rest IE:

    Open IE->click Tools->Internet options->select Advanced tag->click Reset->enable Delete personal settings-> Reset

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Monday, August 29, 2016 2:27 AM
    Moderator
  • All the same.

    http://i.imgur.com/frgO93I.gifv

    Monday, August 29, 2016 7:09 AM
  • Hi S0HardCore,

    Just as my second reply, Make sure your Microsoft account could sign in the Microsoft Home Page successfully. Which could insure the effectiveness of your Microsoft.

    If above scenarios do not work for you. You could try to close your firewall and try log in again in your VS.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Monday, August 29, 2016 9:04 AM
    Moderator
  • Firewall already switched off.

    http://i.imgur.com/WchQgVM.png

    And i already logged.

    http://i.imgur.com/V9P6BM9.png

    And can sign in.

    http://i.imgur.com/FMwK5Ef.gifv

    Monday, August 29, 2016 9:12 AM
  • Hi S0HardCore,

    This issue may be caused by various reasons.

    Please reset user date in your VS, you could do this by the following step:

    Click Start->Developer Command Prompt for VS-> type “devenv /resetuserdata

    Then restart your VS. I hope this will be helpfully for you, please feel free to let me know your result.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Monday, August 29, 2016 9:55 AM
    Moderator
  • http://i.imgur.com/iwAqVLr.png

    Nope.

    Monday, August 29, 2016 5:30 PM
  • Hi S0HardCore,

    According to the error message, please refer to the following scenarios to troubleshoot your issue:

    1). Please check whether you have used proxy in VS. If yes, please refer to the following document to modify it:

    https://msdn.microsoft.com/en-us/library/dn771556.aspx

    2). Please change an another available Microsoft account to sign in again. And update your license.

    3). Please check your internet environment whether it is under the LAN. If your machine in LAN, which could restrict license update.

    If above steps don’t work for you again, I suggest you could update your VS and reinstall your VS.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Tuesday, August 30, 2016 5:12 AM
    Moderator
  • I don't understood 1.

    3. I have router, which connected into PC with cable. I don't think, that it's reason of problem, cause i can sign-in in VS.

    And i deleted VS and all associated with .net. Reinstalled .net and VS. No changes.

    i.imgur.com/lFG4m1x.png


    • Edited by S0HardCore Tuesday, August 30, 2016 3:03 PM
    Tuesday, August 30, 2016 2:48 PM
  • Hi S0HardCore,

    If you have used proxy to access extranet, we could set proxy in Visual Studio.

    We could use devenv /log that log all activity to the log file for troubleshooting. By default, the log file is: %APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml

    Please check your ActivityLog and share here or upload to OneDrive and share a link here. I will find whether it has issues.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Wednesday, August 31, 2016 8:35 AM
    Moderator
  • https://1drv.ms/u/s!AtYUuBTwHvIpa4ZnAD7R6YC_DJ0
    Thursday, September 01, 2016 2:18 PM
  • Hi S0HardCore,

    According to the ActivityLog I found that there are three Error in it (361, 362,363). Which display "The XXX package did not load correctly. ...", please try the following steps to troubleshoot your issue:

    1). Close all instances of VS

    2). delete everything in this 2 folders as below:

    C:\Users\<your users name>\AppData\Local\Microsoft\VisualStudio\14.0

    C:\Users\<your users name>\AppData\Roaming\Microsoft\VisualStudio\14.0

    3). Restart VS 2015

    4). Please open an administrative CMD window and navigate to C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE and run these commands as below, then open VS.

    devenv /resetsettings

    devenv /resetuserdata

    devenv /ResetSkipPkgs

    devenv /safemode

    After each command, please reopen VS to observe whether this issue occurs.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 02, 2016 9:06 AM
    Moderator
  • using the forcibly uninstall command: like "vs_community.exe /uninstall /force" in the
    elevated command prompt to uninstall and then re-install.
    Friday, September 02, 2016 9:58 AM
  • 1, 3 and 4 - nothing

    /resetuserdata - error, which can be fixed by /resetsettings (error tip)

    after this it is does not requires license, but in next launch appears window with select theme, i selected, choose sign in later, and after this again can't update license

    When i type devenv ... it's caused launching VS, i reopen VS, then tried to update -- it's correct actions?

    Kate xin, i reinstalled VS in normal mode. I must type this in cmd ?

    Friday, September 02, 2016 3:09 PM
  • Hi friend,
    This kind issue is a trick problem, because it would be caused by various reasons. I hope the following step will be helpful for you.
    1. This problem may be related to the LSP. You could repair the LSP in you commuter. You could repair the LSP with the third party software or run the following command in cmd.
    >>netsh winsock reset
    I suggest you had better repair the LSP through the third party software. Restart your computer again.
    2. Delete all license information then repair your VS. Please refer to the following link to delete the registry key of VS2015 HKCR\Licenses\4D8CFBCB-2F6A-4AD2-BABF-10E28F6F2C8F.
    Alex’s reply:
    http://stackoverflow.com/questions/12465361/how-to-change-visual-studio-2012-2013-or-2015-license-key/32482322#32482322

    3. According to your above response, you have reinstalled the VS. I suggest that we had better delete all components about VS expect some components about C++ before reinstalling. Then reinstall again. I don’t suggest this steps, please try step 1 and step 2. Good luck.

    • Proposed as answer by qing__Moderator Wednesday, September 07, 2016 9:06 AM
    • Unproposed as answer by qing__Moderator Friday, September 09, 2016 2:12 PM
    Sunday, September 04, 2016 12:44 PM
  • Hi S0HardCore,

    According to gshallkenlmi’s reply, has the issue been solved?

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Tuesday, September 06, 2016 7:34 AM
    Moderator
  • 1. makes nothing

    2. after deleting, repair and reboot i have new license for 30 days, but still i can't update it

    3. I understood correctly: i must delete all C++ packages and reinstall VS normally?

    Only C++ componentrs or may be more?

    http://i.imgur.com/EGXB8SV.png

    Wednesday, September 07, 2016 1:36 PM
  • Hi,

    Deleting all components that corresponding with Visual Stuido throgh Control Panel. Only retain the C++ components. Then re-install the VS, this method could help us uninstall the VS completely. 


    Wednesday, September 07, 2016 2:03 PM
  • In your screenshot such as Microsoft SQL, SQL Server 2014, all components about SQL, Sliverlight.
    Wednesday, September 07, 2016 2:09 PM
  • "Then re-install the VS, this method could help us uninstall the VS completely. "

    Re-install by means of? Control Panel - VS - Delete, then download anew?

    Wednesday, September 07, 2016 3:09 PM
  • Hi S0HardCore,

    As my understanding, gshallkenlmi’s reply means you could uninstall all components about VS except C++ components. Then re-installed the VS by opening the setup file.

    If the setup file does not exist in your machine, you could download the install package from the following site:

    https://www.visualstudio.com/en-us/dn469161#

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Thursday, September 08, 2016 8:17 AM
    Moderator
  • Still cannot update after reinstall.
    Friday, September 09, 2016 1:59 PM
  • Hi S0HardCore,

    I am sorry that this issue exists after above scenarios. Many possible reasons have been considered.

    I suggest that we could try update the license through proxy, we could down load a free proxy and try update again.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 09, 2016 2:39 PM
    Moderator
  • Do you have some recommendations for that? I use router and don't know how to set proxy with him.
    Friday, September 09, 2016 6:18 PM
  • Hi S0HardCore,

    You could download the hide.me VPN for Windows (try for free), after connect successfully then open your VS to update the license again.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Monday, September 12, 2016 12:24 PM
    Moderator
  • Hi S0HardCore,

    Here is a similar issue as you, please refer to the reply of Nicolas Bsag to set the registry key:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/5c544822-fbc5-4e93-956c-8992020b0024/domainjoined-accounts-cant-renew-visual-studio-2015-community-license?forum=vssetup

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    • Proposed as answer by qing__Moderator Wednesday, September 14, 2016 7:45 AM
    Tuesday, September 13, 2016 1:34 AM
    Moderator
  • Hi S0HardCore,

    Have you tried the reply above? Please feel free to let me know your current results. Thank you very much.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Thursday, September 15, 2016 9:12 AM
    Moderator
  • https://social.msdn.microsoft.com/Forums/vstudio/en-US/5c544822-fbc5-4e93-956c-8992020b0024/domainjoined-accounts-cant-renew-visual-studio-2015-community-license?forum=vssetup

    This key missing in regedit (perhaps due to the fact that I have Win 7).

    I create it, reboot and nothing.

    I have not tried VPN. I will write later about the results with the VPN.

    Thursday, September 15, 2016 5:18 PM
  • Hi S0HardCore,

    Thanks for your response, I will to verify this issue whether it occurs in Win7 environment.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 16, 2016 1:53 AM
    Moderator
  • Hi S0HardCore,

    Could you update your VS2015 Community license with VPN? Please feel free to let me know your result.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, September 23, 2016 7:55 AM
    Moderator
  • I tried used USA, UA and Iceland IP addresses, still so

    http://i.imgur.com/WcczDgD.png

    Monday, October 03, 2016 11:04 AM
  • Hi friend,

    I think you had better reinstall your OS. This issue is realted to various reasons. I think reinstall OS is the best method for you.

    Wednesday, October 05, 2016 2:59 PM
  • Okay, I will write about the results, when i will do it.
    Thursday, October 06, 2016 12:41 PM
  • After reinstalling OS it works.
    Tuesday, February 28, 2017 4:55 PM