locked
LAN settings (proxy server) on IE 10

    Question

  • So again, I should ask here my question. When I leave IE 10 or restart Windows 8 Developer IE 10 always forgot my LAN settings (proxy server). What can I do?

    Saturday, September 24, 2011 12:32 PM

Answers

  • Hey Crazytv,

     

    You may want to try using System Restore to return to a point after the refresh but before the setting problem returned. You can use System Restore by:

    • Enter the Start screen
    • Type System Restore
    • Click Settings in the right column
    • Click Restore system files and settings from a restore point
    • Follow the instructions provided in the System Restore window

     

    If you are able to return to a point that your proxy settings are set and work correctly, take note of any Windows or software updates that occur and any software that you install to see if you can identify if an update or installation is what triggers the problem to return.

     

    Hope that helps.


    Steven
    Saturday, October 08, 2011 11:02 PM
    Moderator

All replies

  • crazytv,

    Are you using the desktop version of Internet Explorer 10 or the Metro version?

    How are you going about putting in your LAN settings?

    Thanks,


    Chris
    Saturday, September 24, 2011 1:30 PM
  • Hi Chris!

    I am using the desktop version. For input I click on "Tools" -> "Internet options" -> tab "Connections" -> "LAN settings". Then I put in the Proxy "www-proxy.t-online.de" "Port: 80". After that I choose "Bypass proxy servers for local addresses". Then I click on "Advanced" and type in "Exceptions". Ready with "OK". And that's it.

    Doesn't matter if I run IE 10 "normal" or with "administration" rights, my LAN settings are loose, when I restart Windows or wake after "Hibernate" mode. Sometimes it grant, when I restart IE 10. I use the proxy settings because my broadband connection isn't very fast.

    Last but not least: Hope my English isn't too bad ;-).

    Saturday, September 24, 2011 2:37 PM
  • crazytv,

    Have you made any other changes to you internet options?

    Have you tried a refresh of your machine to see if that fixes the issue?

    Thanks,


    Chris
    Saturday, September 24, 2011 2:56 PM
  • Changes? Actually no. For web connection I have here a "normal" WiFi and "mobile broadband HSPA" network.

    Refresh? Not yet. Should I do? It's a little work because I must deactivate Photoshop and Co. and then refresh or a new complete installation. I don't know, maybe I will do the next few days.

    Saturday, September 24, 2011 3:16 PM
  • One question more, Chris: What's happen when I refresh Windows? Are there the software and my preferences after refreshing? Or Windows delete all?

    Saturday, September 24, 2011 3:37 PM
  • crazytv,

    With the Refresh your PC option, user accounts, user data, and a small set of settings are preserved without the need to first back them up externally.

    * Local accounts, Connected Accounts, and cached domain accounts are preserved.

    * Data defined as everything outside of the following folders is preserved:

    o \Windows

    o \Program Files

    o \Program Files (x86)

    o \ProgramData

    o Per user app data for desktop apps.

    * Settings configured during Windows Welcome and Personalization settings defined in the Windows Metro style Control Panel are preserved.

    * Lock screen background and the User tile are preserved

    * Windows Metro style apps are reinstalled automatically

    o No need to download them from the store again.

    o App settings are reset to their defaults

    * Legacy apps are removed unless they are preloaded by the manufacturer.

    o At the end of the refresh process, an HTML file called “Removed Apps.html” is placed on the desktop with a list of all of the desktop apps that will need to be reinstalled.

    * If Bitlocker is enabled, it will be suspended automatically as part of this process.

    To do a refresh of your machine then please do the following:

    1. Click Start > Control Panel

    2. Select the General section on the left

    3. Click the “Get started” button under “Refresh your PC without affecting your files”.

    4. Click the Next button at the “Refresh your PC” step of the wizard.

    · This first step of the wizard is shown in a green strip that covers the middle portion of the screen.

    · The description text at this step shows the following:

    Here’s what will happen:

    · Your files and personalization settings won’t change.

    · Your PC settings will be restored to their defaults.

    · Apps from Windows Store will be kept. All other apps will be removed.

    5. Insert the USB key or DVD with the Windows installation files if prompted.

    · This description text at this step shows the following:

    Insert your Windows installation or recovery media

    · Some files are missing. The media will provide these files.

    · As soon as you insert the media, the wizard automatically moves to the next step.

    6. Click the Refresh button at the “Ready to refresh your PC” step.

    · This description text at this step shows the following:

    Your PC will restart. This will take a few minutes.

    At this point, the PC will restart and the Push Button Reset process will take over. Once completed, your PC will reboot and the user will be left at the Lock Screen where they can log back in with their existing user account.

    Please post back with the results

    “When you reset your PC your personal files and apps will be removed and your PC settings will be restored to their defaults.”

    Thanks,


    Chris
    Saturday, September 24, 2011 5:25 PM
  • What you can today, don’t do tomorrow ;-).

    I refreshing my PC and yeah, all my apps were gone, Chris. Until yet, the LAN settings are stored in IE 10! I hope it will keep. And because I don’t catch soon faster broadband Wi-Fi, Telekom announced they want to upgrade my mobile broadband network with Long Term Evolution (LTE) technology. It’s good, that Windows 8 shows the consuming GB now.

    Some Windows OT stuff for engineers: My notebook (32bit) never can use “Sleep” mode in Windows Vista/7/8. After wakeup the display is black! He works (LEDs show it) but nothing happen on display. So I always need "Hibernate" mode. Windows also can’t handle the aerator of my NVIDIA GeForce Go 7600, so I use a little program called "CPU Clock" to manage and fix it. Now the aerator is brave. At least: I miss a deactivation-option in Office, like Adobe do.

    Thanks for help, Chris.


    Saturday, September 24, 2011 8:21 PM
  • Try setting a LGPO (Local Group Policy Object).

    1. Open the Group Policy Editor by pressing Start+R and typing gpedit.msc.
    2. Navigate to User configuration|Windows settings|Internet explorer maintainence|Connection|proxy settings
    3. Sorry, I am currently on Windows XP and can't tell if this is the right path for Windows 7/8
    4. Refresh group policy by pressing Start+R and typing gpupdate.
    5. Verify the policy has applied by either pressing Start+R and typing rsop.msc (this will show you the Resultant Set of Policy) or typing gpresult/z at the command prompt.

     

    By the way, are you using ISA Server / TMG? ISA has had problems with its agents that are responsible for setting proxy address on the client domain computers.


    Well this is the world we live in And these are the hands we're given...
    Saturday, September 24, 2011 9:12 PM
  • Hi Exotic Hadron!

    What you are talking about ;-)? Never hear LGPO.

    Refreshing PC was the solution of my problem until yet! No idea why Steven unmarked as answer. I unmarked the other because it’s only a big description of what will happen in and after refreshing process.

    And yeah "Bypass proxy servers for local addresses" is important, because I am a lovely blogger. I use XAMPP with Apache, MySQL and WordPress for local Server experience, maybe you know.

    Sunday, September 25, 2011 3:53 PM
  • Hi Community! A quick update: Refreshing was not the solution. Today IE 10 desktop version forgot my LAN settings (proxy server) after wakeup from Hibernate.

    Maybe it's an IE 10 bug because of young Windows Developer Pre-evolution status. A look forward, it will be fixed soon.

    Tuesday, September 27, 2011 12:04 AM
  • Thank you for posting your feedback, we want to make sure we get the right info including your log files.  Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview.  There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here


    Marilyn
    Wednesday, September 28, 2011 5:44 PM
    Moderator
  • Hi Marilyn, I'll do, I transfer some missing driver stuff and this problem here. edit. I do right now...


    • Edited by jm2c Basti Thursday, September 29, 2011 4:07 PM Not will, I do ;-).
    Thursday, September 29, 2011 4:02 PM
  • Short note for all testers: Be careful with refreshing your system!

    Because Expression Web has no deactivation option, my product key is killed! After refreshing you must installing all your apps again. And now in installation process Expression Web app says to me: "product key invalid", I think because it's already activate. I contact the Expression Web support team...

    Thursday, September 29, 2011 8:16 PM
  • To bring Expression Web alive format c: was solution. Horrible, but it works again on a fresh complete Windows Developer installation. Maybe this problem here is also fixed. I'll see the next days. Keep in mind: Refreshing doesn't fix it!
    Sunday, October 02, 2011 3:29 AM
  • Today, after restarting Windows all LAN (proxy server) settings are kicked. I give it up...
    Monday, October 03, 2011 8:13 PM
  • I don't want to open a new thread. Any ideas why there is an orange exclamation mark on Network icon in taskbar? My Wi-Fi connection works correct.
    Monday, October 03, 2011 8:43 PM
  • Try going to Control Panel|System and Security|Action Center and choosing Troubleshooting applet.

    Might me you're having IP conflict or your IP address has not been assigned and Windows automatically assigned an APIPA (169.254.0.0/16) address for your LAN adaptor.


    Well this is the world we live in And these are the hands we're given...
    Tuesday, October 04, 2011 2:13 PM
  • Hi again Exotic Hadron ;-).

    Well, the Troubleshooting applet finds no trouble. I use FRITZ!Box Fon WLAN 7390 for Wi-Fi connection. When I click on network icon I can see all my networks: dial network, Wi-Fi and mobile broadband HSPA.

    Wi-Fi is now active and show "Limited" but I have full access to the web? It's a little bit strange.


    • Edited by jm2c Basti Wednesday, October 05, 2011 1:20 PM
    Wednesday, October 05, 2011 1:20 PM
  • Short update: After restarting there is no orange exclamation mark anymore. Don't know what's happen, does not matter.

    I am following your step by step instruction Exotic Hadron. When I look into rsop.msc, there all my proxy settings saved. But not shown at "Internet options" in IE 10 desktop version? So, without settings no proxy server ;-(.

    Thursday, October 06, 2011 1:24 AM
  • Hey Crazytv,

     

    You may want to try using System Restore to return to a point after the refresh but before the setting problem returned. You can use System Restore by:

    • Enter the Start screen
    • Type System Restore
    • Click Settings in the right column
    • Click Restore system files and settings from a restore point
    • Follow the instructions provided in the System Restore window

     

    If you are able to return to a point that your proxy settings are set and work correctly, take note of any Windows or software updates that occur and any software that you install to see if you can identify if an update or installation is what triggers the problem to return.

     

    Hope that helps.


    Steven
    Saturday, October 08, 2011 11:02 PM
    Moderator