locked
there has been an error while processing the form/ form closed RRS feed

  • Question

  • 1. User tried to start approval workflow (sharepoint out of box workflow)

    2. User got this error message:

        Warning: There has been an error while processing the form.

    3. Click "Exit Form"

        Form has been closed.

    4. Note: Other users have no problem.

    5. Only this happnens to this user everytime she tried. (Os: Window 7)

    Wednesday, February 22, 2012 8:17 PM

Answers

  •  

    Hi,

    First, you should make sure the user has proper permission for this action. Did this issue happened to other users who have the same permission? And you can suggest this user to use another machine to see if problem persist. If this user could completed this action in another machine successfully, this issue may be caused by a required dll for this option hasn’t registered in the register, you can try to execute the following command to fix it:

    regsvr32 "C:\Program Files\Common Files\Microsoft Shared\OFFICE14\htmlchkr.dll"

    Please check this: http://dinushaonline.blogspot.com/2011/04/infopath-2010resolving-there-has-been.html

    Thanks


    Pengyu Zhao

    TechNet Community Support

    • Marked as answer by Pengyu Zhao Friday, March 2, 2012 6:28 AM
    Wednesday, February 29, 2012 6:28 AM

All replies

  • How is your workflow configured to start?

    Do the permissions for the user vary from the other users?

    Is this a custom InfoPath form?


    Chris Caravajal MCTS SharePoint911 Consulting & Support Services

    Wednesday, February 22, 2012 8:21 PM
  •  

    Hi,

    First, you should make sure the user has proper permission for this action. Did this issue happened to other users who have the same permission? And you can suggest this user to use another machine to see if problem persist. If this user could completed this action in another machine successfully, this issue may be caused by a required dll for this option hasn’t registered in the register, you can try to execute the following command to fix it:

    regsvr32 "C:\Program Files\Common Files\Microsoft Shared\OFFICE14\htmlchkr.dll"

    Please check this: http://dinushaonline.blogspot.com/2011/04/infopath-2010resolving-there-has-been.html

    Thanks


    Pengyu Zhao

    TechNet Community Support

    • Marked as answer by Pengyu Zhao Friday, March 2, 2012 6:28 AM
    Wednesday, February 29, 2012 6:28 AM