locked
cannot resolve assembly in Blend 4 RRS feed

  • Question

  • I have a project that has been working fine up until this morning... I didnt change anything and now I cant build in Blend (note that VS build works fine), I get the error:

    Could not load file or assembly 'System.Core, Version=2.0.5.0 ...(cant be bothered typing all of the error)...' or one of its dependencies. The located assembly's manifest does not match the assembly reference.

    I looked in the references for the app and System.Core should be referencing version 4, not 2, I have no idea why blend is looking for version 2.0.5.0??? I can fix it and cant use blend because I need to build the app in order for the view to appear!

    Please help me out here, its very frustrating!

    Thursday, January 6, 2011 10:42 PM

All replies

  • The assembly version of System.Core.dll in SL 4 is still 2.0.5.0, but the file version is 4.0.50401.0 (this depends on the exact version you have installed).

    Did the SL version for this project change at some point, as in it was originally SL3, but you changed it to SL4?

    If you can't figure it out, I'd be happy to take a look at the solution if you want to zip it and send it to me at first.last@microsoft.com using my name.

    Friday, January 7, 2011 2:35 PM
    Moderator