locked
An error has occurred during report processing. (rsProcessingAborted) RRS feed

  • Question

  • Hello  all,

    I'm using Sqlserver 2008 R2 Developer edition and i've created the small report and it is working in my computer , when I'm browsing form another computer it is not working  for another user and I have  give full access.

    • An error has occurred during report processing. (rsProcessingAborted)
      • Cannot create a connection to data source 'MyDB_TEST'. (rsErrorOpeningConnection)

    For more information about this error navigate to the report server on the local server machine, or enable remote errors


    Regards, Vik
    • Edited by VKommineni Thursday, May 19, 2011 10:05 PM typo eroors
    Thursday, May 19, 2011 10:05 PM

Answers

  • I have figured it out.

    Solution for above problem is

    I Mgt Studio. Add the user as a Login.
    then Click Properties and navigate to User Mappings page
    Put a check mark on the Database that the report is trying to access (apart from ReportServer and ReportServerTempDB)

     


    Regards, Vik
    • Marked as answer by VKommineni Monday, May 23, 2011 6:11 PM
    Monday, May 23, 2011 6:10 PM
  • That is what I meant when I said - Are you sure that the other user has required access to SQL Server?
    • Marked as answer by VKommineni Thursday, May 26, 2011 10:33 PM
    Monday, May 23, 2011 6:17 PM

All replies

  • How is your datasource configured? Are the credentials stored on the report server? 
    Thursday, May 19, 2011 10:10 PM
  • I used  embeded dataset in my report... Could you explain what credentials are to be stored in the Report Server.

     

    Regards, Vik

     


    Regards, Vik
    Thursday, May 19, 2011 10:20 PM
  • What credentials are you using in your dataset?
    Thursday, May 19, 2011 10:34 PM
  • I didn't use any credentials while creating data set.
    Regards, Vik
    Thursday, May 19, 2011 10:51 PM
  • Sorry I mean the data source. 
    Thursday, May 19, 2011 11:15 PM
  • I checked the data source (Shared data source) properties. Its showing  do not use credentials
    Regards, Vik
    Thursday, May 19, 2011 11:41 PM
  • You'll see the following options in data source properties. Please let us know which one among the following have you selected.

     

    <label for="ui_rdoPromptUser">Credentials supplied by the user running the report</label>

    <label for="ui_rdoStored">Credentials stored securely in the report server</label>

    <label for="ui_rdoIntegrated">Windows integrated security</label>

    <label for="ui_rdoNone">Credentials are not required</label>

    Friday, May 20, 2011 4:40 AM
  • Windows integrated security
    Regards, Vik
    Friday, May 20, 2011 4:21 PM
  • Hi,

    Try this:-

    1. Go to your Shared Data Source, open the one which you are using for your rdl file.

    2. General Tab, click on "edit button"

    3. Select "Use Windows Authentication" also double check your Server-Name & Database-Name and hit "Test connection".

    4. If Tested successfully than hit OK OK twice.

     

    Now see by previewing your rdl file.

     

    Please let us know your feedback.

    Thanks

    Kumar


    KG, MCTS
    Friday, May 20, 2011 4:35 PM
  • @ Kumar .

     

    I followed the steps you provided. and tried to access the report on another machine in the same network but getting the same error.


    Regards, Vik
    Friday, May 20, 2011 5:41 PM
  • Hi Vik,

    Is everything working on BIDS side?

    Let us go step by step process.

    Thanks

    Kumar


    KG, MCTS
    Friday, May 20, 2011 5:44 PM
  • I used Report Builder to build report and deployed it on Report server.
    Regards, Vik
    Friday, May 20, 2011 6:08 PM
  • Hi Vik,

    Please double check your DataSource "MyDB_TEST" on your Report Server.

    Is it Tested successfully?

    Thanks

    Kumar


    KG, MCTS
    Friday, May 20, 2011 6:23 PM
  • YES Connection is successful..


    Regards, Vik
    Friday, May 20, 2011 6:36 PM
  • Hi,

    Now, try re-attached the above successful DataSource to your report file and Apply and preview the report.

    Does that help you out?

    Thanks

    Kumar


    KG, MCTS
    Friday, May 20, 2011 6:39 PM
  • Are you sure that the other user has required access to SQL Server?
    Friday, May 20, 2011 6:54 PM
  • @ Shahfaisal

    I m using SQL server developer edition. IS that the reason why i am unable to get the report on another machine.


    Regards, Vik
    Friday, May 20, 2011 10:19 PM
  • @ Kumar

    I tried re-attaching the above successful DataSource to your report file. But couldn't access the report on another machine.

     


    Regards, Vik
    Friday, May 20, 2011 10:22 PM
  • I have figured it out.

    Solution for above problem is

    I Mgt Studio. Add the user as a Login.
    then Click Properties and navigate to User Mappings page
    Put a check mark on the Database that the report is trying to access (apart from ReportServer and ReportServerTempDB)

     


    Regards, Vik
    • Marked as answer by VKommineni Monday, May 23, 2011 6:11 PM
    Monday, May 23, 2011 6:10 PM
  • That is what I meant when I said - Are you sure that the other user has required access to SQL Server?
    • Marked as answer by VKommineni Thursday, May 26, 2011 10:33 PM
    Monday, May 23, 2011 6:17 PM
  • Hi, 

    I am running into same error, but my environment is different.

    My data source is a cube (analysis service) and i am deploying my SSRS report to Sharepoint.

    What would be the solution?

    Thank you,

    Wednesday, August 13, 2014 3:44 AM
  • I tried checking for Credentials as well, and it works (y)
    Thursday, May 5, 2016 1:37 PM
  • An error has occurred during report processing. (rsProcessingAborted)
    • Cannot create a connection to data source . (rsErrorOpeningConnection)

    For more information about this error navigate to the report server on the local server machine, or enable remote errors

    Though report is populated in BIDs, When I Upload it to the report server it does not work. Can someone please help me .


    Tuesday, January 10, 2017 7:16 PM