none
"Windows could not start the service on a local computer" RRS feed

  • Question

  • I  have created a WCF library with windows service and  i have installed my service using installutil and it is successfully installed but i am unable to start the service.When i start the service i am getting below error

    "Windows could not start the Service1 service on a local computer"

    Error 1067:The process terminated unexpectedly.

    This is the example i have followed

    http://msdn.microsoft.com/en-us/library/ff649818.aspx

    Friday, August 23, 2013 4:13 AM

Answers

All replies

  • Hello chandu123,

    Welcome to MSDN forum.

    This forum is to discuss the ClickOnce deployment technology as well as using Windows Forms controls . Your question is not related to the topic of this forum.

    From your description, this thread is related to WCF forum which is more suitable for it.

    You'll need to post it in the dedicated WCF Forum for more efficient responses, where you can contact WCF experts.

    WCF forum :http://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=wcf

    Thanks for your cooperation.

    Have a nice day!
    Damon


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Saturday, August 24, 2013 11:58 PM
  • Hi,
    What is the service account you choose, please try to switch to an admin or system account to see whether the error remains. Also, if the problem occurs at service's startup time, you can check the windows eventlog to see whether it cnotains detailed error information.

    Also please make a try/catch in the service to get some information.

    For WCF service level, please try to turn on the tracing to get more information.
    #Configuring Tracing:
    http://msdn.microsoft.com/en-us/library/ms733025.aspx?PHPSESSID=50d760d9b862023e2c39e99ef0c83e42 

    And it seems that you have solved your problem in:
    http://forums.asp.net/t/1930858.aspx/1?Windows+could+not+start+the+service+on+a+local+computer .

    Best Regards,
    Amy Peng


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.


    Monday, August 26, 2013 3:06 AM
    Moderator