locked
local host debugging RRS feed

  • Question

  • User1528733403 posted

    Hi,

    Why is it when I start debugging my application in VS2008 for this certain project the debugger starts debuggin in

    localhost:1222/Main.aspx

    insted of

    localhost/MMS/main.aspx

    How can I make the debugger go to "locahost/MMS/Main.aspx" rather then "locoalhost:1222/Main.aspx"?

     

    Thanks in advance.

    Thursday, September 24, 2009 9:45 AM

Answers

  • User-1161063654 posted

    Open up the project properties for your web site.  Either right-click on the project and choose 'Properties' or select it from the Project | XXX Properties file menu option (where XXX is the name of your project).

    A new tab will open up and display options for you.  The very last option should be a Web option.  Select that.  You should see Start Actions, Servers, and Debuggers.  Under the Servers container you can configure your web to use IIS rather than the file system/development server.  Select the "Use IIS Web Server..." option and configure accordingly.

    Hope this helps!

    - Jesse

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, September 24, 2009 3:12 PM

All replies

  • User312496708 posted

    because the project is setup to work from Fiel system and nOt IIS. If the project is setup in IIS then it will start on the port 80 whcih is normally mapped to localhost.

    Thursday, September 24, 2009 9:59 AM
  • User1320101480 posted

    Hi,

    It is like http://localhost:1541/fileupload/Default.aspx

    If you need to change it to your server name, you need to configure it on your IIS.

    Thursday, September 24, 2009 10:00 AM
  • User1528733403 posted

    Thanks for the prompt reply guys!!

     

    Nihawan,

    can you lead me on the steps to configureing my IIS to fix the problem?

    Thursday, September 24, 2009 11:16 AM
  • User-1161063654 posted

    Open up the project properties for your web site.  Either right-click on the project and choose 'Properties' or select it from the Project | XXX Properties file menu option (where XXX is the name of your project).

    A new tab will open up and display options for you.  The very last option should be a Web option.  Select that.  You should see Start Actions, Servers, and Debuggers.  Under the Servers container you can configure your web to use IIS rather than the file system/development server.  Select the "Use IIS Web Server..." option and configure accordingly.

    Hope this helps!

    - Jesse

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, September 24, 2009 3:12 PM
  • User1528733403 posted

    Thanks Jesse!!

    your post answer my question!!!!! 

    Thursday, September 24, 2009 3:22 PM