locked
Potential problem with web app session variables and iPhones (?) RRS feed

  • Question

  • User625999351 posted

    I have a fairly conventional Dot Net 4.0 (C#) web application that passes around a few session variables between pages.  So far, so good.  

    Now someone ran the app on their iPhone and got a minor error.  The only way this error could occur, so far as I can tell is if a particular session variable were lost in the transition between one page and the next.  

    Is there any factor specific to iPhones and other mobile devices that could account for this?  All conventional use on PCs has been without incident.

    (This app wasn't even designed for mobile devices, although that may yet happen.)

    Monday, February 11, 2013 9:55 AM

All replies

  • User-760709272 posted

    If you are losing the Session then the mobile device is rejecting your site's cookies.

    Monday, February 11, 2013 10:03 AM
  • User-1360095595 posted

    I doubt it, only because session is maintained on the server not the client. So it shouldn't matter where you're accessing your page from. I would think it's something else. 

    Monday, February 11, 2013 10:04 AM
  • User1779161005 posted

    Browsers have limits on the amount of cookie data per-domain:

    http://myownplayground.atspace.com/cookietest.html

    Is it possible that your domain is creating more than 4K of cookie data?

    Monday, February 11, 2013 11:20 AM
  • User625999351 posted

    Actually there's only one cookie in my system and its value is a string that normally will not be more than 20 or so characters.

    Monday, February 11, 2013 1:19 PM
  • User1943143334 posted

    Hi,

    Is it reproducable every time? Moreover, did you tried on other devices?

    Tuesday, February 12, 2013 11:43 AM
  • User625999351 posted

    Actually the problem may be one of communication.  My app was set to a timeout of 300 minutes.  No one told me the company web server was set to 30 minutes.

    The testing continues...

    Wednesday, February 13, 2013 1:24 PM
  • User1943143334 posted

    Hi,

    Any Updates on this issue? Are you still facing it?

    Tuesday, February 19, 2013 2:44 AM
  • User625999351 posted

    Deep in testing right now.  So far, so good.

    Tuesday, February 19, 2013 12:03 PM