locked
The Module DLL C:\Windows\system32\RpcProxy\RpcProxy.dll failed to load RRS feed

  • Question

  • User-58890844 posted

    HI

    I am just posting a solution which took me days to work out and is as usual such a simple fix WHICH I THINK should be fixed by Microsoft.  Thanks also to Anil Ruia for tips on how to fix this

    Scenario:

    64Bit IIS7 running a 32Bit application so Enable 32Bit is set to true on the application pool
    Also running as an exchange front end server and hence RPCProxy is loaded

    In this scenario you might get the errors

    In IE -
    "HTTP Error 503. The service is unavailable."

    In the event viewer-
    "The Module DLL C:\Windows\system32\RpcProxy\RpcProxy.dll failed to load. The data is the error."
    and
    "Application pool 'xxxxxxxxx' is being automatically disabled due to a series of failures in the process(es) serving that application pool."

    Essentially the rpcpoxy is trying to load into the 32bit pool.  The question I have i guess is why is this dll trying to load in the first place.  It's not part of my application.  Anyway to fix this issue:

    Edit  c:\windows\system32\inetsrv\config\applicationhost.config

    In the section which has <globalmodules> add -  precondition="bitness64" to the rpcproxy line so that you have the following

    <add name="PasswordExpiryModule" image="C:\Windows\system32\RpcProxy\RpcProxy.dll" preCondition="bitness64" />

    Hope this helps others

    Wednesday, January 7, 2009 6:38 PM

Answers

  • User-2064283741 posted

    Not that I have used it as it is an exchange thing but you asked why it was loaded. Here is the reason:

    http://technet.microsoft.com/en-us/library/bb124035(EXCHG.65).aspx

    Maybe there should be more info about it running under 32 bit here:

    http://technet.microsoft.com/en-us/library/aa996644(EXCHG.65).aspx

    But I see it as more of an exchange problem than IIS.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, January 8, 2009 8:08 PM

All replies

  • User-2064283741 posted

    Not that I have used it as it is an exchange thing but you asked why it was loaded. Here is the reason:

    http://technet.microsoft.com/en-us/library/bb124035(EXCHG.65).aspx

    Maybe there should be more info about it running under 32 bit here:

    http://technet.microsoft.com/en-us/library/aa996644(EXCHG.65).aspx

    But I see it as more of an exchange problem than IIS.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, January 8, 2009 8:08 PM
  • User1728746126 posted

    Brilliant, just ran into this trying to get TS Gateway up and running on IIS7.

    Tuesday, January 20, 2009 5:59 PM
  • User-58890844 posted

    Thanks for the links.  As i read them that explains why rpcproxy is on my machine which i already knew.  What i don't understand is why my application, which has nothing to do with outlook, is trying to load this dll.  Or did i miss something in the articles?

     Thanks

    Tuesday, January 20, 2009 6:11 PM
  • User-2064283741 posted

    I can only imagine it (via Exchange) was installed at some point on your box. Another query here about rpcproxy was that they were running on Small Business Server so they had exchange and it installed this.

    To be honest I know little about it as I have not worked with it but they are the conculsion I would make initially. I also understand it is an ISAPI filter, do you have any references to any filter on your machine (server wide or any of the sites?). Any reference to it in your metabase?

    Tuesday, January 20, 2009 7:54 PM
  • User-58890844 posted

    Yes it's setup up on the box, it's supposed to be as it's an Exchange Front End server.  What i don't know is why it's loading up in my application.  Other applications on the same server require it so thats why it's there.  It's not in the list of handlers for my application so it's a bit confusing.  ANyway it all works fine now with the workaround i posted

     Thanks

     

    Tuesday, January 20, 2009 9:48 PM
  • User-1099190964 posted
    After looking hours for a solution I found this http://support.citrix.com/article/CTX120153. Maybe it'll help someone.
    Sunday, December 6, 2009 3:44 PM
  • User-1763818489 posted

    Good morning all,

    I know this is an older thread but I'm coming across this exact issue with a new SBS2008 server for one of my clients.  The time/attendance app they are installing has a Web services component and is a 32-bit application, so I enabled 32-bit compatibility on the app pool for that specific program.  Now I get 503 -Service unavailable errors and the RPCproxy.dll error which causes the app pool to shut down.  When I added the argument to the <globalmodules> "PasswordExpiryModule" as instructed above, I now get an error on the same application: 

     HTTP 500.19 - the worker process is unable to read the applicationhost.config file.  

     If I revert to the saved applicationHost.config, it goes right back to the RPCproxy.dll issue.

    I followed the syntax to the letter!  I don't understand why it would have trouble reading the applicationhost.config file after I added that line preventing the RPCproxy.dll file from being called....any help would be MUCH appreciated.  Thanks!

     

     

    -Dave Roberts

     

    Tuesday, June 15, 2010 12:20 PM
  • User-1201427832 posted

    Im experiencing the same issues as Dave with the RPCproxy.dll error, any help would be appreciated

    Tuesday, June 15, 2010 3:58 PM
  • User-123865099 posted

    The fix worked for me, thank you so much.

     

    The format of mine looks as follows:

     

                <add name="PasswordExpiryModule" image="C:\Windows\system32\RpcProxy\RpcProxy.dll"
    preCondition="bitness64"  />
     

    Wednesday, June 16, 2010 1:35 AM
  • User-1727753169 posted

    Dave,

    i had the same problem and after some digging i found this article

    http://www.m86security.com/kb/article.aspx?id=12671

    follow it and your site should be running

     

    Dani Avni

    Sunday, August 1, 2010 4:21 AM