none
Workflow variables RRS feed

  • Question

  • While I've been maintaining SharePoint servers for a log time, only recently i started to dab into workflows.  I am struggling to understand how data is passed from the "collect data from user".  For example if I want to collect car_type, car_color, and car_value from the user,  I will assign these variables in the task, then set it to car:ID as the place holder.  When is time to email someone the info, i can't seem to find the correct car:id and values within the car: id.  Any help would be greatly appreciated. 


    Saturday, December 13, 2014 5:15 PM

All replies

  • Hi

    this article explains how to get value from collect data from user

    https://support.office.com/en-ie/article/Collect-data-from-a-user-in-a-workflow-a1758bcc-6a93-4ca9-9b55-7821b91e80f4?ui=en-US&rs=en-IE&ad=IE

     if you needed more help let me know


    Kind Regards,

    John Naguib

    Technical Consultant/Architect

    MCITP, MCPD, MCTS, MCT, TOGAF 9 Foundation

    Please remember to mark your question as answered if this solves your problem

    Sunday, December 14, 2014 8:42 AM
  • Hi John and thanks for your reply.  This is the same document i am trying to follow.

    1.  I have followed the document to the letter.  The problem is when set and done, in the "Define Workflow Lookup" i do not get the source as task.   I am using designer 2013 but all my workflows are created on 2010 platform.  My screen looks like:

    Data Source:  "Association:Task List"  is the only lookup available field i can return "Review Status"

    2. The bottom data binding is even more confusing:

    There is no "workflow data" field available.  I only have "Workflow ID, Workflow list ID, and Workflow name" which none returns the correct values.

    3.  The document describes getting and storing two string Values " Reject and approved".  But following the document I don't see this happening.  I am guessing that I have to use the "set workflow variables" twice:  one for approved and one for reject to use at the later time.

    Greatly appreciate for any help. 


    Tuesday, December 16, 2014 6:48 PM
  • Hi,

    Are you using the approval workflow? if this is the case so i think you need to create your own workflow


    Kind Regards,

    John Naguib

    Technical Consultant/Architect

    MCITP, MCPD, MCTS, MCT, TOGAF 9 Foundation

    Please remember to mark your question as answered if this solves your problem

    Wednesday, December 17, 2014 8:16 AM