none
SharePoint 2013 Workflows RRS feed

  • Question

  • Hi there

    I seem to be having trouble running any workflows using the 2013 engine in SharePoint Designer. The 2010 workflows work fine, however I cannot seem to get the 2013 ones to even start. Looking at the list/library settings, I can see the workflow has been added but for whatever reason it doesn't seem to start.

    I cannot even go back into a list item to view the workflow either...

    Where to I even begin to try to unravel this mystery? HELP!! :-)

    Many thanks in advance.

    Monday, April 20, 2015 8:38 AM

Answers

  • SharePoint 2013 Workflow engine has undergone a drastic change. Before you begin developing workflows in SharePoint 2013 you must ensure you have taken care of the pre-requisites.

    Ensure you have gone through each points in this article in configuring your Workflow Manager 2013:

    https://technet.microsoft.com/en-us/library/jj658588.aspx

    Before you start installing/developing SharePoint Workflows in 2013 you should to know few important points:

    • Never use ‘System Account’ to develop/run workflow, the workflow will fail to run.

    • You should not use ‘System Account’ to test the workflow.

    • You need to make sure User Profile Service (UPS) is running and the user who is running workflow has a profile created in UPS. Workflow Manager use UPS under the hood.

    • Make sure App Management Service is created and running. You don’t need to configure SharePoint 2013 App settings in the server, just creating App Management service (with proxy) will do.

    • Make sure the hidden feature WorkflowServiceStore is enabled.
    Enable-SPFeature -Identity WorkflowServiceStore –Url $yourUrl

    Note: To register Workflow Server with SharePoint, a SharePoint site collection URL is provided. Apparently it seems, each and every site collection need to be registered with workflow server. But it’s not, registering a single SharePoint site collection, will enable workflow manager for all SharePoint web applications/site collections.

    Now you can check from above listed points, which points resolves your issue.

    More detailed troubleshooting steps on SP workflows 2013:

    http://blogs.msdn.com/b/vincent_runge/archive/2014/01/07/troubleshooting-actions-for-sharepoint-2013-workflows.aspx


    Please remember to click 'Mark as Answer' if the reply answers your query or 'Upvote' if it helps you.

    Monday, April 20, 2015 10:28 AM