none
Visual Studio 2017 - SSIS Project Incompatible RRS feed

  • Question

  • Hi All,

    I created and have been working on a VS2017 SSIS SSDT solution for the past week. Visual Studio crashed a little while ago and after the restart the toolbar message said xxxx plugin caused the crash, click disable after restart never see this message again.

    I clicked disable and restart now Visual Studio says my SSIS solution is incompatible and I can't open it, either starting Visual Studio then select the solution or right clicking and selecting open with.

    So how do I re-enable SSIS packages?

    Thanks

    Thursday, April 12, 2018 6:11 AM

All replies

  • Hi,

    Welcome to MSDN forum.

    Do you get the problem with the other SSIS project?

    >>Visual Studio crashed a little while ago and after the restart the toolbar message said xxxx plugin caused the crash, click disable after restart never see this message again.

    Was the plugin installed by yourself?

    You can create a new SSIS project to check it if the plugin affect SSIS project. The latest SSDT for Visual Studio 2017 is (15.6.0), if you have problem with a new SSIS project, try to install it.

    https://docs.microsoft.com/en-us/sql/ssdt/download-sql-server-data-tools-ssdt

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, April 13, 2018 3:24 AM
  • Hi Cameron,

    Did you manage to solve this issue? I have the same problem...

    Wednesday, April 25, 2018 5:15 PM
  • I have the same issue. I updated SSDT to the latest version today and VS 2017 is on the latest version (15.7.1). I can create a new SSIS project no problem but existing SSIS projects fail to load telling me they are incompatible. These projects were created with an earlier version of VS 2017.

    Is there some way to upgrade these SSIS projects to the latest version or import them into a new project?

    Thursday, May 10, 2018 10:55 AM
  • I had the same issue on two separate occasions. I am using Visual Studio Community 2017 with SSDT for Visual Studio 15.6.0. OS Windows 8.

    I followed the steps below which resolved my issue and Visual Studio recognised the Solution and SSIS Projects. 

    Go to Control Panel -> Programs -> Programs and Features

    Find Microsoft Visual Studio Installer in the list of programs installed on your PC/Laptop.

    Right Click on this line and click 'Change'. This will open the Installer, and you should see two products in the Installed section - Microsoft SQL Server Data Tools and Microsoft Visual Studio.

    Under Microsoft SQL Server Data Tools -> Click on 'More' and select 'Repair' option. 

    This should open another window where I believe some packages are downloaded and installed. On both occasions the downloaded size was around 450 MB. Apologies I could not take a screenshot of that process. 

    Once the download and installation is complete, your PC/Laptop will require a Restart. You should automatically get a message to restart your machine. Please do so. 

    Upon restart, open Visual Studio 2017 and then load the Solution you were trying to open. It should open as normal along with the relevant Projects. 

    This has worked for me on more than one occasion, so thought to share this to Developers just in case this also resolves their issue. 

    Can you please try this and let me know if this resolves your problem. 

    • Proposed as answer by clem1196 Thursday, February 21, 2019 9:24 PM
    Saturday, May 12, 2018 6:55 PM
  • Morning - Has anyone resolved this issue.

    I have tried the suggest Repair. No help.

    Each day I have to build a new project and add my dtsx's.

    tx-g

    Monday, July 2, 2018 2:20 PM
  • I have a similar issue. I tried to use VS 2017 to open some SSIS projects that were developed by VS 2015, but it shows incompatible error message, and I can't open the SSIS projects.

    Does anyone ever had the same issue and fix it?

    Thanks

    Tuesday, July 3, 2018 9:38 PM
  • If you right-click on your solution in SSDT, you have an option call "Resolve errors" or something like that in the middle of the menu. When I clicked on it, my solution has been corrected.

    I have version 15.7.4 of SSDT.

    For me, it's the solution!

    Wednesday, July 4, 2018 7:49 PM
  • I'll try to repair but the process failed... any idea?
    Thursday, July 5, 2018 7:01 AM
  • "Resolve errors" worked for me as well after reinstalling. Thanks for your help.
    Friday, July 20, 2018 2:43 PM
  • If you right-click on your solution in SSDT, you have an option call "Resolve errors" or something like that in the middle of the menu. When I clicked on it, my solution has been corrected.

    I have version 15.7.4 of SSDT.

    For me, it's the solution!


    This worked for me!!
    Wednesday, August 15, 2018 9:00 AM
  • If you right-click on your solution in SSDT, you have an option call "Resolve errors" or something like that in the middle of the menu. When I clicked on it, my solution has been corrected.

    I have version 15.7.4 of SSDT.

    For me, it's the solution!

    The said above worked for me only once. Next time when I open my project again the same issue. Please help

    Wednesday, August 22, 2018 1:45 PM
  • I just used Tools --> Extensions and updates, look for the disable extension (Microsoft Integration Services Projects) and enable it again, after that close and reopen visual studio, go to Solution explorer right click on your solution and select Resolve errors, that fixed the issue for me.
    • Proposed as answer by Eli11c Friday, September 7, 2018 4:55 PM
    Monday, September 3, 2018 7:53 PM
  • This worked for me,  thanks!
    Friday, September 7, 2018 4:53 PM
  • This option worked perfectly, i had more than 1 week trying to fix this issue until i found your answer.

    many thanks!!

    Thursday, September 13, 2018 7:04 PM
  • Hi Cameronh,

    Its a old thread but for those that face same issue its a really (stupid) issue, whe you open a SSIS project it taka a long time to load and VS himselft "SUGGEST" DISABLE SSIS EXTENSION what causes you cannot open/create none SSIS Project, to "FIX" this issue just Open Visual Studio --> Tools-->Extensions & Updates --> SSIS Integration Services Projects and click on "ENABLE".

    For me this no matters with VS/DataTools versions. 

    Hope this will be helpful.

    Friday, September 21, 2018 5:23 PM
  • I STRONGLY support the suggestions that since SSDT and VS have been nominally "integrated" I have wasted hours on the times the two teams did NOT succeed. Installing the latest VS update then failed to update Analysis Services and Reporting Services. Trying to update one at a time failed, all due to incompatible requirements/versions. I uninstalled one, updated the other and reinstalled. Today I discovered the same "feature" disabled SSIS packages. Finding that repairing VS did NOT resolve the problem, I found a suggestion to uninstall Analysis Services and Reporting Services, and then install the SSDT standalone update.

    This is NONSENSE! I have wasted hours. I would be much happier with the old system of updates about twice/year. If Microsoft wants to update frequently, it is IMPERATIVE that those updates actually work smoothly. It still takes too much time even when the updates work, but it's ridiculous when I have to spend hours troubleshooting and hunting for solutions.


    Paul

    Monday, October 1, 2018 7:51 PM
  • I concur Paul,

    Have spent more than a day now installing/uninstalling/updating SSDT & Visual Studio
    Everytime a new error seems to pop up.
    Latest error I get when creating a new SSIS project: 'could not load file or assembly "Microsoft.DataWarehouse"'

    This all looks very messy...

    Barry 


    • Edited by Barry dB Wednesday, October 3, 2018 8:55 AM
    Wednesday, October 3, 2018 8:54 AM
  • Ditto Paul Barry and Cameronh

    The SSIS project I developed and have run for several months crashed.  Project became "Incompatible".  Cannot update SSAS or SSRS.  I can re-enable the project but it still crashes and the process starts over.  I guess I'm down to ripping VS out and starting over.  BTW, my packages do run on my laptop without problems just not on my DEV Desktop machine.  Thanks for the info.  I hope someone is listening....


    Mario

    Sunday, October 7, 2018 4:28 PM
  • If you right-click on your solution in SSDT, you have an option call "Resolve errors" or something like that in the middle of the menu. When I clicked on it, my solution has been corrected.

    I have version 15.7.4 of SSDT.

    For me, it's the solution!

    This is the solution for me.

    if it is not for you.

    Try this :

    First, repair your SSDT installation.

    After this, try above.

    Sunday, November 4, 2018 7:49 PM
  • Hi

    Just upgrade VS til 15.8.9 and executed the 'Resolve errors' - this fixed the problem for me - for now !


    Paul S


    Thursday, November 8, 2018 8:16 AM
  • Sometimes a right-click 'Reload Project' works. Still perplexed why this is happening!


    Lee Everest


    • Edited by Lee Everest Wednesday, November 21, 2018 5:21 PM
    Wednesday, November 21, 2018 5:19 PM
  • Thank you. This worked for me.
    Tuesday, November 27, 2018 3:14 AM
  • Thanks this worked. Try right click on the solution and say resolve errors if it does not work straight away. 
    Sunday, December 30, 2018 8:39 AM
  • This solution worked for me!

    Thanks !

    Monday, January 7, 2019 4:38 PM
  • thanks ,

    this solution worked for me , 

    First  : I start by Opening  Visual Studio --> Tools-->Extensions & Updates --> SSIS Integration Services Projects and click on "ENABLE".

    Second : I right-click on  solution in SSDT, I click  an option call "Resolve errors"

    So for me the usage of both solution give me the soution .

    thank you All .

    • Proposed as answer by Shadow229 Tuesday, February 5, 2019 11:45 AM
    Wednesday, January 23, 2019 2:57 PM
  • I recently had this problem after updating Visual Studio 2017 to version 15.9.6. (January 2019)

    After opening the project in Solution Explorer I saw "MySSISProjectName (incompatible)" like at picture above.

    What I did:

    In Command Prompt run

    "C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.6.1 Tools\x64\gacutil.exe " /l Microsoft.Build.Framework

    to check what I have in  Global Assembly Cache.

    In my case I saw

    Microsoft.Build.Framework, Version=2.0.0.0, 

    Microsoft.Build.Framework, Version=3.5.0.0

    Microsoft.Build.Framework, Version=14.0.0.0

    Microsoft.Build.Framework, Version=15.1.0.0

    Microsoft.Build.Framework, Version=4.0.0.0

     Then I run 

    "C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.6.1 Tools\x64\gacutil.exe " /u "Microsoft.Build.Framework, Version=15.1.0.0"

    to uninstall v. 15.1.

    After that run Visual Studio, open your project, right  click in Solution Explorer, Reload Project.

    That's all.

    To reinstall Microsoft.Build.Framework in Global Assembly Cache in case you need it use

    "C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.6.1 Tools\x64\gacutil.exe "/i "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\Bin\Microsoft.Build.Framework.dll"

    Check your path, I use Visual Studio Community.

     


    • Edited by IgoKalja Wednesday, January 30, 2019 5:31 PM
    Wednesday, January 30, 2019 5:31 PM
  • Had similar issue when system hang and apparently thought I navigated to the button to disable the add on for integration services.  A repair of SSDT 2017 worked allowing me to create a new package with the solution explorer and import the prior packages from the project showing the incompatible message but could never open the prior project without the issue.
    Thursday, January 31, 2019 3:21 PM
  • thanks ,

    this solution worked for me , 

    First  : I start by Opening  Visual Studio --> Tools-->Extensions & Updates --> SSIS Integration Services Projects and click on "ENABLE".

    Second : I right-click on  solution in SSDT, I click  an option call "Resolve errors"

    So for me the usage of both solution give me the soution .

    thank you All .

    Exactly what I had to do. Thanks to all for the solutions!
    Tuesday, February 5, 2019 11:46 AM
  • I just used Tools --> Extensions and updates, look for the disable extension (Microsoft Integration Services Projects) and enable it again, after that close and reopen visual studio, go to Solution explorer right click on your solution and select Resolve errors, that fixed the issue for me.
    Thanks, this helps.
    Sunday, February 10, 2019 10:00 PM
  • gracias he solucionado con esto mi problema

    clemente de la cruz

    Thursday, February 21, 2019 9:24 PM
  • It is interesting.  I have reinstalled Integration Services on Visual Studio 2017 several times.  My best guess at this point it there is a strange message that suggests disabling a feature (in my case integration services 2.1) will improve performance.   I believe it does nothing of the kind but instead, disables integration services entirely forcing the user to reactivate it.  Meanwhile, it will appear that the package is "incompatible".

    Quite frustrating I might add.  If you see the message, my advice is to ignore it.


    • Edited by krakdcorn Thursday, March 7, 2019 12:20 AM
    Thursday, March 7, 2019 12:20 AM
  • This was exactly my issue!!! Thank you for pointing it out.
    Thursday, March 7, 2019 2:31 AM
  • Great !!! this works for me. 
    Wednesday, March 20, 2019 7:01 AM
  • I used the solution with the Control Panel to ensure I had the latest software. However, I still needed to use the Resolve Errors solution to finally get everything to work. I right clicked the Solution within the Solution Explorer to display the Resolve Error option.

    Hope this helps someone else.

    


    • Edited by DCommonCold Friday, March 29, 2019 1:16 PM clarification
    Friday, March 29, 2019 1:15 PM
  • To resolve this "Incompatible" project issue, I found out that I need to first reinstall the "Prerequisites for SSDT" that appears in Control Panel\Programs\Programs and Features, then reinstall the SSDT itself, and then apply the Resolve Error trick many have suggested above. Missing the first step to reinstall "Prerequisites for SSDT", the rest of the steps didn't help me resolve the issue.

    I spent many hours in vain to reinstall VS 2017 + SSDT till I finally figured out the missing step. While this may not be what's required for others who encountered this issue, I guess this findings may help some who need it.

    Microsoft should have fixed their bad "Incompatible" check for project or provide more useful troubleshooting clues for us to correct such frustrating issue.


    Sunday, March 31, 2019 4:38 AM
  • What worked for me:

    • On Windows 7 and VS 2017
    • Open Control Panel / Programs and Features
    • Found 2 versions of Data Tools installed
    •  - Microsoft SQL Server Data Tools - Visual Studio 2017
    •  - Microsoft SQL Server Data Tools for Visual Studio 2017
    • Uninstalled both (took a couple of hours)
    • Installed Microsoft SQL Server Data Tools - Visual Studio 2017

    Good luck

    20%in30days


    John C Svercek

    Wednesday, April 17, 2019 8:42 PM
  • Worked for me, thank you

    Monday, May 6, 2019 5:31 AM
  • This worked for me. Thanks a lot for this info.
    Tuesday, May 7, 2019 4:08 PM
  • You are the man!!!
    Thursday, May 30, 2019 4:28 AM
  • It worked perfectly for me ... Great thanks :-)
    Monday, June 3, 2019 1:29 PM
  • I cannot find "Resolve errors" when I right click the project in "Solution explorer". But there is a "Reload Project". Clicking the reload project also get my project back after enable Integration Service in "Extensions and Updates".
    Tuesday, June 11, 2019 11:05 PM
  • I just used Tools --> Extensions and updates, look for the disable extension (Microsoft Integration Services Projects) and enable it again, after that close and reopen visual studio, go to Solution explorer right click on your solution and select Resolve errors, that fixed the issue for me.
    I cannot find "Resolve errors" when I right click the project in "Solution explorer". But there is a "Reload Project". Clicking the reload project also get my project back after enable Integration Service in Menu bar "Tools" / "Extensions and Updates".
    Tuesday, June 11, 2019 11:07 PM
  • This is the correct step since only SSIS plugin was disabled.
    Monday, June 17, 2019 9:44 AM
  • Thanks it works for me.
    Friday, June 28, 2019 2:41 AM
  • Thank you, Thank you, Thank you clem1196!!!

    I was fighting this issue for 2 1/2 days with no end in sight. 

    I was sure it was a client issue with VS 2017 but everything I was reading pointed to server side solutions. 

    This answer needs to promoted to a tech note or handed to the MS techs as a goto doc for this issue.

    I followed your steps and then did a "Reload Project" and boom the project link switched from "incompatible" and restored all my project tree files to normal.

    Thank much again!!

    jsmart377


    • Edited by JSmart377 Friday, September 20, 2019 3:30 PM
    Friday, September 20, 2019 3:30 PM
  • Thanks it works for me
    Tuesday, October 8, 2019 1:03 PM
  • Thank you so much !! Worked for me after so many tries :)
    Monday, November 11, 2019 8:27 PM