none
Internet Explorer 8 hanging when opening a XML RRS feed

  • Question

  • Hi everyone,

             I have a problem with Internet Explorer 8. I have written a webserver i VB.NET and I can successfully connect to it and navigate; this webserver can also product XML pages based on result of database queries.

    Well, the problem is that Internet Explorer 8 is slow opening these XML sheets. I tried IE6, Firefox, Opera and with these browser the XML page is displayed in less then a second, while Internet Explorer 8 is SLOW opening this page - about 10 seconds; obviously, the more complex the page is, the more IE8 hangs opening it, while other browsers (even the "good oldie" IE6) open it in a second. While loading the XML IE8 is stuck on 50% load of my CPU (which is dual core, so it's one core full load).

    Is this a IE8 limitation, or have I to "preprare" this page for IE8 to be parsed quickly? Have to add some special tag to the XML for Internet Explorer 8?

    I uploaded the file to my SkyDrive: the link is http://cid-e5f7f1eb86592278.office.live.com/self.aspx/Pubblica/SQLWEB.xml.

    I hope that someone can help me,

     

    Marco

     

    ps.: even with ie7 the loading is immediate, and the XML file appears to be valid using online validators; the problem appears using both Windows XP and Windows 7.

    pps.: another detail: opening the XML as a "local" file saved on the desktop, results in immediate loading; opening it from a remote address results in the ie hang.

    Friday, June 18, 2010 8:15 AM

All replies

  • Up! :) Nobody has a solution? Is there an I.E.8 limitation on XMLs?

    I say sorry to moderators, but I can't really figure out this problem!

    -Marco

    Thursday, June 24, 2010 7:16 AM
  • No there is no limitation in IE8 on XML. IE8 comes with the most features in all web browsers.

    Try viewing your XML file with some other browser like Firefox. (Google Chrome does not support XML files but the new version might). If your file opens in other browsers.

    uninstall and Reinstall IE8 and make sure you install the stable version and not the beta. Then try updating IE8 from Microsoft Update.

    You might have to add some special tag for XML it is not compatible but i dont think its required, if it is try finding it on MSDN Library > IE


    CREATING SOMETHING CREATIVE. http://karankash.webs.com
    • Proposed as answer by Karan Kashyap Thursday, June 24, 2010 8:39 AM
    • Unproposed as answer by redbytes Thursday, June 24, 2010 5:51 PM
    Thursday, June 24, 2010 8:39 AM
  • As I wrote in my first post, ALL browsers open this file immediately. Only IE8 - yes, up-to-date - on ALL operating systems - XP, Vista, Seven - hangs on this file.

    I tried to find a "special" tag to solve the problem, but I can't find it.

     

    Thursday, June 24, 2010 5:54 PM
  • I have had the same Issue.  Windows 7 IE8 patched up to date with both the x86 and x64.   Firefox works and my wife's MAC Safari and Firefox.   Just IE8 with problems. 

     

     

    End tag 'title' does not match the start tag 'span'. Error processing resource 'http://feeds2.feedburner.com/~r/EvgaNewsRss...

     

    <?xml version="1.0" ?><rss version="2.0"><channel><title>EVGA News RSS Feed</title><link>...

     

    Friday, July 16, 2010 11:22 PM
  • Just wondering if you've found a solution to your problem. I'm experiencing the exact same behavior with IE8. My CPU core is at 50% and IE8 locks up whereas older IE versions like IE6 and IE7 handle the XML on my site just fine. 
    Friday, October 8, 2010 12:33 AM
  • Hi,

    Your problem may be completely different? You are making an assumptions that you are perfect and don't make mistakes in your markup or xml schema...We also need to inspect your site's response headers to make sure it is sending back the correct content type.

    Please provide a link to your validated web site if you need assistance.

    CPU throttling is usually associated with Flash and/or graphics processing.... Try adding your site to the Restiricted sites zone where active scripting is disabled by default. If your undesclosed issue on your unknown site disappears then it is your scripting of your site/Flash content.

    Possibly also your page has many markup errors and is tripping the IE8 error handling and trying to reload the page in IE7 Emulation mode. See Internet Options, Advanced tab, "Recover from redering errors with Compatibility View"


    Rob^_^
    Friday, October 8, 2010 6:54 AM
  • Yep...

    the error messag says it all

    End tag 'title' does not match the start tag 'span'. Error processing resource 'http://feeds2.feedburner.com/~r/EvgaNewsRss...

    go to validator.w3.org and validate the rss feed url... they have a xml validator there too.

    Regards.


    Rob^_^
    Friday, October 8, 2010 6:56 AM