None of the network adaptators are bound to the netmon driver RRS feed

  • Question

  • Hello,

    I have installed NetMon 3.3 successfully but when I try to run a capture, I get the following error message:

    None of the network adaptators are bound to the netmon driver.
    You may not have the rights to capture on this machine. Your account must be in the Administrators group to capture.

    - I had a look in the "Select Networks" tab and no network adaptator at all appear here
    - I tried to stop/restart the nm service as suggested in another thread and I get the message: Error 1060, service doesn't exist (I translated this from the french error message ;))
      So it appears the nm service wasn't correctly installed: how could this happen ?

     - I'm using XP-SP3, and am running as administrator, so this isn't a right problem I guess.

    Tuesday, June 23, 2009 10:03 PM

All replies

  • On XP and Windows 2003, the Network Monitor Driver is built into the OS.  So it's possible that this component was not included when you installed your OS or the driver is not enabled for the NIC. The tricky part is trying to figure out how to install it as I've not seen this on XP before.

    Can you go to Control Panel, Network Connections, and then right click and access the properties of the NIC you want to trace on.

    Then see if there is a selection for Netmon driver in the list.  If not, see if you can add a it.  To do this, select Add, then choose Protocol and see if Netmon driver shows in the list.  If not I will have to do some more research.


    Wednesday, June 24, 2009 2:29 PM
  • First, thanks for your help.

    I went to Control Panel/Network Connections, properties and couldn't see anything related to Netmon in the list. I tried to Add a new protocol, and in the listed protocols, I only have:

     - Microsoft tcp/ip version 6
     - Protocole de transport compatible NWlink ipx/spx/netbios (in french)

    That's it. Nothing related to netmon... I guess I'm stuck there.
    Thursday, June 25, 2009 9:53 PM
  • I think one way around this is to install the support tools on the XP CD.  There is a utility that is called NetCap, which is like NMCap for NM3.3.  I'm thinking this might install the driver and make it availalbe when you add the protocol from the driver list.

    Let me know if that works.


    Friday, June 26, 2009 2:04 PM
  • I see this error on windows server 2008 r2 with netmon 3.4, just run a repair installation fix it for me.
    Monday, May 27, 2019 1:09 AM