none
XSLT 2.0 & 3.0 is support in .net RRS feed

  • Question

  • Hi,
    We are using VS2013 and using XSLT1.0. With XSLT1.0 we are able to get the result from <g class="gr_ gr_13 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins doubleReplace replaceWithoutSep" data-gr-id="13" id="13">XML</g> file. Now we have a requirement to use XSLT2.0.
    Is VS2013 or later versions have support to use XSLT2.0?
    If not, Is there any alternate ways to use XSLT2.0?

    Thanks,
    Kiran
    Wednesday, June 19, 2019 3:49 AM

All replies

  • Hi Kiran,

    • Unfortunately, the .Net Framework is stack with the XSLT 1.0 standard, circa 1999-2001.
    • The newer .Net Core 3.0 didn't make any progress either.
    • The best option is to use Saxonica product. Saxonica
      They support Java, .Net, and c/c++.
      Their product supports XSLT 3.0, XQuery 3.1, XSD 1.1, and XPath 3.1.

    Wednesday, June 19, 2019 4:00 AM