none
Unable to uninstall/install WCFLOB Adapter +Non Upgradeable version of wcf lob adapter sdk already exist RRS feed

  • Question

  • We are getting this error "Non Upgradeable version of wcf lob adapter sdk already exist" when trying to install WCF LOB Adapter Framework Pack in BizTalk 2016 on windows 10

    1.There is no registry key under the path"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WCF LOB Adapter SDK\3.0\"

    2.There is no entry in the Add/Remove Programs.

    Any help will be appreciated.

    Thanks


    • Edited by vinutha CA Monday, August 20, 2018 9:12 AM
    Monday, August 20, 2018 8:33 AM

All replies

  • Hi,

    It looks like the MSI you are using for LOB Adapter Pack does not support the OS version(32 or 64 bit issue) i would recommend you to check the correct version of LOB Adapter Pack before Installing(Refer Link#1). also make sure all prerequisites must be fulfilled to successful installation.

    Also look at the list of Support Line Of Business Adapter for different BizTalk Server versions (Refer Link#2).

    Or lastly try with below option

    msiexec.exe /x ProductID /quiet /passive

    • /x uninstall the product;
    • The the ProductID of the adapterframework64.msi, which is GUID and you will have to find that one in registry (productID (GUID) looks like this: {123D4FDD-E1C2-678A-8F9C-6FD5287659D0})
    • /quiet - No user interaction;
    • /Passive -Unattended mode - progress bar only.

    Link#1 https://docs.microsoft.com/en-us/biztalk/adapters-and-accelerators/software-prerequisites-for-biztalk-adapter-pack-2016

    Link#2 https://social.technet.microsoft.com/wiki/contents/articles/17631.biztalk-server-supported-line-of-business-lob-and-enterprise-systems.aspx

    HTH


    Hope this Helps!!!! Regards, Note: Please Mark As Answered if you satisfy with Reply.

    Monday, August 20, 2018 10:18 AM