locked
System.IO.FileNotFoundException: The Web application at http://mysiterurl could not be found RRS feed

  • Question

  • I got new VM and its environment is
    -Windows server 2003 standered edition with SP2. OS is 64 bit.
    -MOSS 2007 with SP2
    -Microsoft Visual Studio Team System 2008 Development Edition Microsoft .NET Framework 3.5 SP1
    -Visual Studio 2008 extensions for Windows SharePoint Services 3.0 (version 1.2)
    -Microsoft SQL Server 2008
    I get the ADMIN rights on this VM. some one else installed all the softwares with his admin rights(not with Administrator id).
    there are two site collection are created on this web application.

    Now I am trying to develop simple web application using sharepoint object model that update the list item of list. But I get the error

    System.IO.FileNotFoundException: The Web application at http://mysiterurl could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application.

    I google it for this error and tried to solve as per the suggesstion as other faces same kind of problem. I tried to add Alternate Access Mapping url but it is not working. I checked site collection administrator, I am the site collection administrator.

    I tried with to set platform 'x64' instead of anyCPU in VS 2008 but still same error. I verified the sharepiont 12.0.0.0 Assemblies in the GAC.

    but when I create package using sharepoint object model in my old VM and deploy solution on new VM it is working fine. It seems to me like permission Issue but what is the solution?

    Any help really appreciated. I spent lot of time but couldn't resolve this problem.
     

    Friday, September 17, 2010 2:04 PM

All replies

  • I don't know if this will work for your issue but my issue sounds similar to the one you are having. In Sharepoint I edited my Alternate Access Mapping URL which you said didn't work for you.  I changed my internal URL to //localhost which is my local machine. This also changed my public URL to the same thing.  However, it didn't work right away.  I don't think it initally changed my Public URL so make sure you have both pointing to your local machine. 

     

     

    Tuesday, November 2, 2010 3:44 AM