none
.net 4 error on Win7 - Cant install error code: (0xC0000006) RRS feed

  • Question

  • Hello,

    Im trying to install .net 4 framework on win7 and I get an error: 

    Screen shot: http://3dbids.com/07_03_12_21_12_20.png

    Screen shot 2:  http://3dbids.com/07_03_12_21_12_57.png

    Screen 3: http://3dbids.com/07_03_12_21_14_37.png 

    Installation log: 

    <center>

    Installation Log

    </center>
    Message Types: <input id="errCB" type="checkbox" /> <label class="pointer" for="errCB" style="cursor:pointer;">Errors</label>   <input id="vbeCB" type="checkbox" /> <label class="pointer" for="vbeCB" style="cursor:pointer;">Verbose</label>   <input id="msgCB" type="checkbox" /> <label class="pointer" for="msgCB" style="cursor:pointer;">Messages</label>  
    Message Details: <input id="tCB" type="checkbox" /> <label class="pointer" for="tCB" style="cursor:pointer;">Date Time</label>   <input class="button" style="background-color:#f0f0f0;border-top-width:1px;border-right-width:1px;border-bottom-width:1px;border-left-width:1px;" type="button" value="Summary" />  <input class="button" style="background-color:#f0f0f0;border-top-width:1px;border-right-width:1px;border-bottom-width:1px;border-left-width:1px;" type="button" value="Expand All" />  <input class="button" style="background-color:#f0f0f0;border-top-width:1px;border-right-width:1px;border-bottom-width:1px;border-left-width:1px;" type="button" value="Collapse All" /> 
    <center style="font-family:Verdana;font-size:13px;line-height:normal;background-color:#f0f0f0;">© 2009 Microsoft Corporation. All rights reserved. Terms of Use.</center><form action="file:///C:/Users/Ciprian/AppData/Local/Temp/Microsoft%20.NET%20Framework%204%20Setup_20120307_211112026.html" class="messages" id="messages" style="font-size:9pt;font-family:Arial;background-color:#f0f0f0;border-top-width:medium;border-top-style:solid;border-top-color:#c0c0c0;overflow-x:hidden;overflow-y:hidden;width:1488px;line-height:normal;">
    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1
    CommandLine = D:\8483500f759543d07a521655b8\\Setup.exe /x86 /x64
    TimeZone = GTB Standard Time
    Initial LCID = 1033
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
    Number of applicable items: 11
    Exe (D:\8483500f759543d07a521655b8\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (D:\8483500f759543d07a521655b8\Windows6.1-KB958488-v6001-x64.msu) failed with 0xc0000006 - (null).
    Final Result: Installation failed with error code: (0xC0000006) (Elapsed time: 0 00:01:41).</form>

    I have no ideea how to fix it, any suggestions ?

    Thank you !




    Wednesday, March 7, 2012 7:13 PM

Answers

  • You should follow Alexander Sun's suggestions on Windows Installer repair in this thread:

    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/9f3e6515-32ce-4163-8496-8d7835de2a55 

    You can also try this sequence:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Before running the installer, apply irarab's fix as follows:

    "I went to "C:\Windows\Microsoft.NET" there is a directory called "assembly".

    I looked in the directory and found some subdirectories with lots of old dot net 4 files. I renamed the directory assembly2 and tried to install Dot Net 4 and it worked!!!!

    (You can't delete the assembly directory unless you take ownership of it but you can rename it.)"

    Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Collect your full install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&amp;displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Thursday, March 8, 2012 12:54 AM