none
Issues registering test agent RRS feed

  • Question

  • I have an environment set up for my team project to run a build, deploy test.

    My TFS machine, TestController and my virtual machine used for the environment are all on the same domain. The TFS and Test controller services both run using the same domain administrator account.

    When I created my environment in Lab Management, I used this same domain account in the 'Advanced' tab when configuring the environment to run UI tests.

    When I run the Verify, I get this error:

    The credentials provided for configuring the test agent to run as process are not valid. Provide valid credentials.

    I can log into the VM using this domain account fine. The only way I can get it to validate in Lab Management is if I create a local account with the same username and password and use .\USERNAME instead of DOMAIN\USERNAME, but the problem there is when it's configuring the environment I end up getting this:

    Environment message: Type=Error; Message=TF259625: The environment is 'Not Ready' because there is a problem in either the test controller or test agents installed on the machines. Click 'Repair'. If the problem persists, use the Environment Viewer to connect to the machines which are not ready and view event logs.;

    Machine message: Type=Error; Message=The agent can connect to the controller but the controller cannot connect to the agent because of following reason: The requested name is valid, but no data of the requested type was found. Make sure that the firewall on the test agent machine is not blocking the connection.

    I have the firewall turned off on the TestController and VM 

    Any ideas?



    • Edited by Timber P Thursday, March 28, 2013 3:35 PM
    Thursday, March 28, 2013 3:14 PM

All replies

  • Been testing setting up the test agent manually and have this in the error log. i get an error when the agent tests the connectivity to the controller

    Test agent process started successfully.
    Verifying that the test agent is able to connect to the test controller.
    Could not get the status from the test agent. Exception: Failed to connect to an IPC Port: The system cannot find the file specified.
    Could not get the status from the test agent. Exception: Failed to connect to an IPC Port: The system cannot find the file specified.

    Thursday, March 28, 2013 11:27 PM
  • Hi,

    Thank you for your post.

    Hope you can help collect following information to narrow down the issue.
    1. What's the version of your TFS, MTM, test controller, test agent?

    2. What's the kind of test environment you want to create?

    3. Do test controller and test agent run on same machine?

    I test the issue with MTM 2012, TFS 2012 deployment. I create standard environment. If you are using TFS 2012, MTM 2012 too. Please check following information:
    1. In "Machines" step, please use an account which is a member of administrators group on the machine.

    2. Please do not install test agent on the machine, test controller will install test agent on the machine.

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, March 29, 2013 6:50 AM
    Moderator
  • For those who still are looking for an answer, here is my solution. All these steps were executed on the test controller / test manager machine (which is the same machine in my case) :

    1 - I'm not sure if this is related to my problem but this was something I did before the following steps. At some point I've tried to install the VS Agents separately to the test agent machine. It didn't help to solve my problem but I could see to which machine it was being registered. After executing one of the following steps (I can't remember which one) I saw it being registered to a machine name which was on the test controller's hosts file pointing to 127.0.0.1. I've deleted those records from the hosts file. Now the localhost is pointing to 127.0.0.1 and after completing these steps the test agent is being registered to the test controller with the right machine name.

    2 - Since I have two network adapters on the test controller/manager machine, I've added the "bind to" key to the QTControllerConfig.xml file according to this article http://support.microsoft.com/kb/944496/en-us 

    I didn't add it to the QTAgentService.exe.config on the Test Agent and to the QTAgent.exe.config on Test Controller.

    (I don't believe that this step was necessary but it's worth mentioning)

    3 - On the test controller, I've deleted the cache in this directory : C:\Users\username\AppData\Local\Microsoft\Team Foundation\4.0\Cache

    This step does not solve the issue by itself.

    4 - I've deleted the record about a former environment from the file QTControllerConfig.xml which is located at C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE.

    After these steps I could finally install the test agent to my virtual machine from the test manager.


    • Edited by enmosarge Friday, October 11, 2013 8:36 AM missing step
    Friday, October 11, 2013 8:16 AM