locked
HTTP 500 error 0x800700aa loading .asp pages RRS feed

  • Question

  • User-799039264 posted

    64.
    n
    n
    i
    ISAPI_START 21:01:40.516
    65.
    n
    n
    i
    CALL_ISAPI_EXTENSION DllName="C:\Windows\system32\inetsrv\asp.dll" 21:01:40.516
    66.
    n
    n
    i
    ISAPI_EXTENSION_DONE 21:01:40.657
    67.
    n
    n
    r
    MODULE_SET_RESPONSE_ERROR_STATUS
    Warning
    ModuleName="IsapiModule", Notification="EXECUTE_REQUEST_HANDLER", HttpStatus="500", HttpReason="Internal Server Error", HttpSubStatus="0", ErrorCode="The requested resource is in use. (0x800700aa)", ConfigExceptionInfo="" 21:01:40.657
    68.
    n
    n
    i
    ISAPI_END

    This is the failed request tracking entry that points to the problem (I think). Although, I don't know how to resolve "The requested resource is in use."
    This happens for every .asp page -- all .htm pages are fine. This application was working at one point, but something happened recently to prevent it. I don't know what.

    Here is the entry in the IIS log that pertains to this request:
    #Software: Microsoft Internet Information Services 7.0
    #Version: 1.0
    #Date: 2007-11-13 21:01:40
    #Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status
    2007-11-13 21:01:40 192.168.11.6 GET /services.asp - 85 - 192.168.11.6 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+Media+Center+PC+5.0;+.NET+CLR+3.0.04506) 500 0 170

    Things I tried and checked:

    • 32 bit apps enabled in IIS
    • allocated app to classic .net pool
    • tried hitting a basic/stripped ASP page to test
    • reinstalled IIS
    • reinstalled ASP
    • checked all permissions for IUSR in application directory and in inetsvr directory
    • tried using an administrator account instead of IUSR
    • UAC is off
    • ran regsvr32 on asp.dll and other related DLLs
    • enabled the tracing and got that message above
    • system and application event logs have no related entries
    • unplugged pc, threw across room, plugged back in -- same error

    My system:

    • IIS 7
    • Vista Ultimate x64
    • 2gb RAM
    • Athlon 64

    Can anyone tell me what I should look for to correct this? Thanks in advance.

    Edit: procmon shows this when I hit the page -- it's all I can dig up that might have something to do with this:

    Sequence: 72121
    Date & Time: 11/13/2007 4:16:44 PM
    Event Class: File System
    Operation: FASTIO_ACQUIRE_FOR_SECTION_SYNCHRONIZATION
    Result: FILE LOCKED WITH ONLY READERS
    Path: C:\Windows\SysWOW64\inetsrv\asp.dll
    TID: 4412
    Duration: 0.0000075
    SyncType: SyncTypeCreateSection
    PageProtection: 

    Tuesday, November 13, 2007 4:07 PM

Answers

  • User-1012857663 posted

    Ok I think I fixed it. After I followed the followign steps it worked for me.

    In IIS Manager choose View Application Pools
    then choose Set Application Pool Defaults.
    Then under Process Model set Identity to LocalSystem.

     

    Let me know if it works

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, November 29, 2007 11:16 AM

All replies

  • User1073881637 posted

    A good toss always makes you feel better. :) You've tried quite a bit, thanks for posting.  I don't have an Vista 64 bit box handy, can you check ISAPI and CGI restrictions and make sure ASP is enabled.  That is one thing that stands out right now. 

    Wednesday, November 14, 2007 12:12 AM
  • User-799039264 posted

    ASP is indeed "allowed" in the restrictions. I guess I forgot to mention that one.

    Wednesday, November 14, 2007 10:08 AM
  • User-799039264 posted

    Too tough for y'all, I take it. This is driving me insane. I am now uninstalling and reinstalling things again. /cry

    Wednesday, November 28, 2007 2:45 PM
  • User511787461 posted

    This is not something we have seen and there seems to be no way to get to the bottom of this without debugging it - so your options are

    a) Come up with repro steps which can help us repro this problem in-house

    b) call up microsoft support and ultimately get someone from support to debug the problem

    c) reinstall and (hopefully) the problem goes away

    Thursday, November 29, 2007 12:40 AM
  • User-1012857663 posted

    I am also getting the same error. I am running Vista Business. I have tried everythign I could think of and still get the follwoing:

    Url: http://localhost:80/apprisenet/enter-pass.asp
    Site: 1
    App Pool: DefaultAppPool
    Process: 6356
    Authentication: anonymous
    User from token: NT AUTHORITY\IUSR
    Activity ID: {00000000-0000-0000-0B00-0080010000FD}
    Failure Reason: STATUS_CODE
    Final Status: 500
    Time Taken: 32 msec

    IIS Trace Detail Highlights

    No. EventName Details Time
    43.
    n
    n
    r
    MODULE_SET_RESPONSE_ERROR_STATUS
    Warning
    ModuleName="IsapiModule", Notification="EXECUTE_REQUEST_HANDLER", HttpStatus="500", HttpReason="Internal Server Error", HttpSubStatus="0", ErrorCode="The requested resource is in use. (0x800700aa)", ConfigExceptionInfo=""

    Thursday, November 29, 2007 9:30 AM
  • User-799039264 posted

    I am at wit's end. I'm rebuilding the machine. It was working before and I don't know why it won't now. For me, every ASP page fails. Even a page that has one line of code in it for testing. Extremely frustrating.

    Thursday, November 29, 2007 9:51 AM
  • User-1012857663 posted

    Yes...I am runnign through the same problem. This was working a couple weeks ago no problem...every ASP page now gives me that error. Htm files are ok though. I tried different directories and the same problem. Just so frustrating when you know something worked a couple days ago and now it does not. Vista is evil. 8-)

    Thursday, November 29, 2007 9:54 AM
  • User-1012857663 posted

    Ok I think I fixed it. After I followed the followign steps it worked for me.

    In IIS Manager choose View Application Pools
    then choose Set Application Pool Defaults.
    Then under Process Model set Identity to LocalSystem.

     

    Let me know if it works

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, November 29, 2007 11:16 AM
  • User-799039264 posted

    OH

    MY

    GAWD!!!!!!!!

    I absolutely KNEW it was a simple setting!! I was ready to delete my partition. Thank you so so so so much for posting. I got my response.write to appear -- no 500 error. OMGOMGOMGOMGOMGOMG!!!!! WEEKS OF TORTURE HAVE ENDED!!!

    THank you, again. <3

    Thursday, November 29, 2007 11:22 AM
  • User-1012857663 posted

    Glad it worked out for you. 8-)

    Thursday, November 29, 2007 1:28 PM
  • User511787461 posted

    Note that you would probably not want to run the application pool as LocalSystem in a production environment, this would increase your exposure to any security issue - this indicates that there was something that NetworkService could not get permission for, surprised that you did not see anything in the process-monitor logs.

    Monday, December 3, 2007 2:18 AM
  • User-799039264 posted

    Setting this up with Vista has been absolutely painful. I made it work for local testing purposes and it's now using SpecificUser instead of NetworkService or LocalSystem so that I can specify an administrator account on the machine. If I don't do this, none of my database calls work.

    I couldn't get SQL Server 2005 to install on Vista either and have VMware running XP x64 so I can connect to it. The setup is nuts, but it works. My production environment is third-party hosted and does not involve Vista... so none of this is an issue.

    Monday, December 3, 2007 10:00 AM
  • User-536568293 posted

    I have the same problem, but after changing the identity of the application pool from "NetworkService" to "LocalSystem", all ASP pages start working, but any asp application that uses the Application, Session or Server objects now fail (and that is pretty much all ASP applications).

     I now get an error like this:

    "error '8002801d'
    /Default.asp, line 4"

     Where on that line is either code using Application, Session or a Server object. All other code above that works. These pages used to work about a week ago. I did not change anything in the ASP files or anything else. Please help, I have tried everything, including uninstalling and reinstalling IIS and ASP. It still does not work.

    Monday, January 7, 2008 1:53 PM
  • User989702501 posted

    Well this is the first time I see 'resource in use' for IIS 7 :)

    If it works via LocalSystem, then I suggest you check if NetworkService has read&execute permission for asp.dll. If it is then need to figure out where networkservice having access issue. Get Procmon from MS and trace it.

    Monday, January 7, 2008 11:06 PM
  • User562339722 posted

    I have a similar problem.  I set up and was working and what I did was I run a test website in visual studio 2008 and then I couldnt view classic asp pages again .  generating error 500 .  Tracing gives me  ErrorCode: 0x800700aa.  It also tells me that  Execute_request_handler: The requested  resource is in use(0x800700aa)  I checked and found out that asp.dll was not set up but can also not be found in the resources available to add.  Strange.  I am using vista business.

    Wednesday, June 11, 2008 7:55 AM
  • User1405114533 posted

     I am having a nearly identical problem. My classic asp pages work until I use one of the Application, session or server objects, then I get the '8002901d' error as well. Checking Event Viewer / Windows Logs / Application, I have the following entry each time the page is executed

    "Error: The Template Persistent Cache initialization failed for Application Pool 'ASP.NET 1.1' because of the following error: Could not create a Disk Cache Sub-directory for the Application Pool. The data may have additional error codes.."

    These asp pages worked fine until I installed Vista Service Pack 1, then all fail. I've already lost the restore point to before SP1 was installed, and uninstalling SP1 did not resolve. I've tried every suggestion I could find on the web for IIS 7 setup, but nothing so far has fixed this for me.

     HELP!!!
     

    Wednesday, June 18, 2008 3:48 PM
  • User-1532439024 posted

    HOLY CRAP!!! 

    I've been trying to resolve this problem for months. I finally gave up on classic ASP on my Vista machine and kept another older box around specifically to maintain 1 application. I just came across this post last night and now I'm off and running.

    Can't thank you enough, alopez2007. I had to register here just to give you a shout... really... thanks a bunch!

    tj

    Thursday, July 17, 2008 1:36 PM
  • User-122931624 posted

     I'm looking for solution few days in a row now and even this fix is not working for me.

    Still http 500 with error code 0x800700aa.

    Removed/installed few times too ... any other way to fix this? I need it fixed badly.

     Thank you

    Thursday, July 30, 2009 1:59 PM
  • User1356161706 posted

    This is late but here is an instance of the problem:

    One of our PSS guys just troubleshooted this issue with a customer. Here is the reason.

    The issue was that McAffee  overwrote the entry  below for Vbscript.dll with its own entry but this was not removed when McAfee was uninstalled.   <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p><o:p> </o:p><o:p> </o:p>HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32<o:p></o:p>    (Default)    REG_SZ    C:\Program Files\McAfee\VirusScan\scriptsn.dll<o:p></o:p>

    Hope this helps

    Thursday, January 21, 2010 1:48 PM
  • User979595217 posted

     Replace that registry key with C:\Windows\system32\vbscript.dll to fix the issue. It's confirmed in my case as well.

    Thursday, February 18, 2010 1:41 PM
  • User989702501 posted

    Ha! took so long :p but at least now we know what cause the resource in use issue.

    Monday, February 22, 2010 12:12 AM
  • User-1725224607 posted
    what if my registry entry has oleaut32.dll for InprocServer32. Should that be updated to vbscript.dll? I have other pools servicing asp pages fine, just this classic pool is failing so i am hesitant to make a registry change that could break other applications/pools. Thanks.
    Tuesday, December 28, 2010 5:05 PM
  • User-1725224607 posted
    Sorry looking at wrong id... B54F3741-5B07-11cf-A4B0-00AA004A55E8 is pointed at vbscript.dll ... back to the drawing board.
    Tuesday, December 28, 2010 5:17 PM
  • User989702501 posted
    still stuck with the error ?
    Wednesday, December 29, 2010 1:50 AM
  • User-1725224607 posted
    Saddly yes. I am unable to reinstall as production currently running under this pool aspx pages work fine. I have tried/verified the registry entry as stated in thread. Swapped the users for the pool, from ApplicationPoolIdentity to LocalSystem to even one of our domain administrators. Hesitant, but today going to try taking a backup using the appcmd and then running the application from a Integrated Managed Pipeline Mode rather then Classic and see what works/breaks. We have other pools on the box that are in this Integrated Mode that have no issues. Not sure why this one is different. Original person who set-up has moved on. Let me know if you have any bright ideas. Thanks!
    Wednesday, December 29, 2010 9:10 AM
  • User-1725224607 posted
    To clarify, aspx works fine, but asp pages are getting the resource is in use issue. Seems to be the type of page, cause i have made my test asp pages be simply just html and they aren't working. Thanks!
    Wednesday, December 29, 2010 9:14 AM
  • User-1725224607 posted
    Moved the application to a different pool which has asp working and that didn't resolve the problem. Didn't `convert` the application using appcmd. Just moved it. So not sure if that made a difference. Good not it didn't break anything either. Thanks
    Wednesday, December 29, 2010 5:32 PM
  • User989702501 posted

    This is weird.... what's the app pool id of the diff app pool ?

    Monday, January 3, 2011 3:30 AM
  • User-1725224607 posted
    Moved it from the ClassicAppPool-x32 (id 1) to DefaultAppPool-x32 (id 5 i think)
    Monday, January 3, 2011 9:45 AM
  • User989702501 posted

    I mean - the app pool account is local system, services or ?

    Thursday, January 6, 2011 1:09 AM
  • User-1725224607 posted
    Tried a doman user, tried the local system user, tried the applicationpooolidentity default with iis7
    Thursday, January 6, 2011 9:29 AM
  • User-1725224607 posted
    The domain user was a admin domain user....
    Thursday, January 6, 2011 10:58 AM
  • User-1725224607 posted
    So looks like when i comment out <authentication mode="Windows" /> and change the pool identity to localsystem the asp code starts working. The aspx code then fails. Any one see a way to have my cake and eat it too? What is this authentication mode and how can i use it so both asp and aspx pages are happy :)
    Friday, January 7, 2011 3:31 PM
  • User-1725224607 posted
    should say comment out the line that has: authentication mode="Windows"
    Friday, January 7, 2011 3:32 PM
  • User989702501 posted

    Somehow, somewhere, the access permissions were messed up. Forget how you can reset all to the default setup, but here's some info on the account/security changes. http://learn.iis.net/page.aspx/140/understanding-built-in-user-and-group-accounts-in-iis-7/

    it is not recommended to run as localsystem unless it is necessary, you should use back the default app pool id, and then use procmon to trace the asp related error, I mean it should be permission related and procmon should be able to trace it.

    Sunday, January 9, 2011 9:27 PM
  • User320075661 posted

     This solution is not working for me... IIS7 on Server 2008 Datacenter

     

    Enabling Faild Request tracing rules, appear:

     

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
     <System>
      <Provider Name="WWW Server" Guid="{3A2A4E84-4C21-4981-AE10-3FDA0D9B0F83}"/>
      <EventID>0</EventID>
      <Version>1</Version>
      <Level>3</Level>
      <Opcode>16</Opcode>
      <Keywords>0x100</Keywords>
      <TimeCreated SystemTime="2012-04-02T16:41:47.002Z"/>
      <Correlation ActivityID="{00000000-0000-0000-AA01-0080000000F0}"/>
      <Execution ProcessID="12220" ThreadID="83020"/>
      <Computer>CT10580</Computer>
     </System>
     <EventData>
      <Data Name="ContextId">{00000000-0000-0000-AA01-0080000000F0}</Data>
      <Data Name="ModuleName">IsapiModule</Data>
      <Data Name="Notification">128</Data>
      <Data Name="HttpStatus">500</Data>
      <Data Name="HttpReason">Internal Server Error</Data>
      <Data Name="HttpSubStatus">0</Data>
      <Data Name="ErrorCode">2147942570</Data>
      <Data Name="ConfigExceptionInfo"></Data>
     </EventData>
     <RenderingInfo Culture="en-US">
      <Opcode>MODULE_SET_RESPONSE_ERROR_STATUS</Opcode>
      <Keywords>
       <Keyword>RequestNotifications</Keyword>
      </Keywords>
      <freb:Description Data="Notification">EXECUTE_REQUEST_HANDLER</freb:Description>
      <freb:Description Data="ErrorCode">The requested resource is in use.
     (0x800700aa)</freb:Description>
     </RenderingInfo>
     <ExtendedTracingInfo xmlns="http://schemas.microsoft.com/win/2004/08/events/trace">
      <EventGuid>{002E91E3-E7AE-44AB-8E07-99230FFA6ADE}</EventGuid>
     </ExtendedTracingInfo>
    </Event>

     

    Tuesday, April 3, 2012 1:43 AM
  • User989702501 posted
    what isapimodule is this? I mean the request is to what resource?  ASP ?
    Tuesday, April 3, 2012 10:57 PM
  • Wednesday, April 4, 2012 4:08 AM
  • User1032620786 posted

    In my case, it was McAfee, or at least what remained of it after an incomplete uninstall process. This link did help: http://blogs.msdn.com/b/webtopics/archive/2010/02/26/asp-500-error-and-error-code-0x800700aa-when-browsing-a-simple-asp-page.aspx

    Friday, January 18, 2013 12:20 PM