locked
Variation Problem - The Web application at http://localhost could not be found - System.IO.FileNotFoundException RRS feed

  • Question

  • I have two WFE servers node01(the first sharepoint installation) and node02, upgraded from SP2007 with variation English and Arabic, I moved all the manual customizations to node02, I did not configured NLB yet.

     

    I don't know if this is normal, when I try to access the sites from the node02 ( as in http://node02/ ) I get the following error:

    The Web application at http://node02 could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application.

    Line 47: private string GetRedirectTargetUrl()

    Line 48: {

    Line 49: ReadOnlyCollection<VariationLabel> spawnedLabels = Variations.Current.UserAccessibleLabels;

     Line 50: if (spawnedLabels.Count > 0)

    Line 51: {

     

    when I try to browse the full URL http://node02/English/Pages/Default.aspx, it takes a very long time to load, and the variation menu (to select the language) is not rendering (instead an error message)

     

    I have some warning in the event viewer:

    Alternate access mappings have not been configured.  Users or services are accessing the site http://node01 with the URL http://node02.  This may cause incorrect links to be stored or returned to users.  If this is expected, add the URL http://node02 as an AAM response URL

     

    I appreciate any help ...


    It's never too late in life ... to start living

    Monday, November 28, 2011 4:36 PM

Answers

  • I assume node02 is not one of the names in the Alternate Access Mappings of the web application. As this is one node of the farm I assume you used a public name when creating the web app. If you need to access the portal with just one node server name you have to add it to a zone in the AAM settings.
    Stefan Goßner
    Senior Escalation Engineer - Microsoft CSS
    This post is provided "AS IS" with no warrenties and confers no rights.
    Tuesday, November 29, 2011 8:50 AM

All replies

  • any help or clarification, or useful link to follow
    It's never too late in life ... to start living
    Tuesday, November 29, 2011 4:40 AM
  • I assume node02 is not one of the names in the Alternate Access Mappings of the web application. As this is one node of the farm I assume you used a public name when creating the web app. If you need to access the portal with just one node server name you have to add it to a zone in the AAM settings.
    Stefan Goßner
    Senior Escalation Engineer - Microsoft CSS
    This post is provided "AS IS" with no warrenties and confers no rights.
    Tuesday, November 29, 2011 8:50 AM