none
Can I use Entity Framework 4.1 Code First with SQL Server 2005 Express? RRS feed

  • Question

  • Hi all,

    I expected find an answer to this question real easily... But apparently I'm looking at the wrong places...

    Thanks! 

    Monday, October 17, 2011 5:27 PM

Answers

  • Yes, it will work fine with Sql Server 2005 express.  I use it on a daily basis with sql 2008 express and haven't had any problems.  Any auto-generated DDL from  EF should work in sql 2005, sql 2008 , express or non-express versions.

     


    Tom Overton
    Monday, October 17, 2011 5:34 PM
  • On 10/17/2011 1:27 PM, Jebus007 wrote:
    > Hi all,
    >
    > I expected find an answer to this question real easily... But apparently
    > I'm looking at the wrong places...
    >
     
    EF won't work on SQL server 2000 it's too old.
     
     
    Monday, October 17, 2011 9:12 PM

All replies

  • Yes, it will work fine with Sql Server 2005 express.  I use it on a daily basis with sql 2008 express and haven't had any problems.  Any auto-generated DDL from  EF should work in sql 2005, sql 2008 , express or non-express versions.

     


    Tom Overton
    Monday, October 17, 2011 5:34 PM
  • On 10/17/2011 1:27 PM, Jebus007 wrote:
    > Hi all,
    >
    > I expected find an answer to this question real easily... But apparently
    > I'm looking at the wrong places...
    >
     
    EF won't work on SQL server 2000 it's too old.
     
     
    Monday, October 17, 2011 9:12 PM