none
How to suppress the alert or message box "The linked file isn't available...." in word c# RRS feed

  • Question

  •  After updating the document fields I am getting the above alert box.

    Please anyone have solution for it?

    Wednesday, October 24, 2018 12:24 PM

All replies

  • Hi Allipur,

    You could use the following code to suppress the alert.

    Word.Application word = Globals.ThisAddIn.Application;

    word.DisplayAlerts = Microsoft.Office.Interop.Word.WdAlertLevel.wdAlertsNone;

    However you could not completely dismiss alert messages in Word. The best thing to do is try to anticipate the errors that may occur and avoid generating them.

    Please see the following link:

    Word Automation - Disable Alerts

    Hopefully it helps you.

    Best Regards,

    Bruce


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread.

    Thursday, October 25, 2018 7:45 AM
    Moderator