locked
The provider is not compatible with the version of Oracle client !!!!!! RRS feed

  • Question

  • User109322195 posted

    In my machine , both Oracle 10 and Oracle 11 client are installed. I am using Oracle 11 's - Oracle.DataAccess.Client.

    My question is acutal application is working fine. I can able to connect oracle and make transaction. But when i trying to connect from my "Test Project" the following exception showns,

    Test method TestBusinessFacade.BFLExternalApprovalTest.LoadRenewalByIncidentIDTest threw exception:  System.TypeInitializationException: The type initializer for 'Oracle.DataAccess.Client.OracleConnection' threw an exception. --->  Oracle.DataAccess.Client.OracleException: The provider is not compatible with the version of Oracle client.

    I want to know, why it's not woking in Test Project?

     

    Sunday, September 23, 2012 6:17 AM

All replies

  • User269602965 posted

    You only need the Oracle 11g Client installed

    and with that you can access Oracle 91, 10g, and 11g databases.

    Sunday, September 23, 2012 10:32 PM