none
MMC cannat initialize the snap-in RRS feed

  • Question

  • Hei,
    Am running Server 2008. We have about 3500 users in many scopes ... in the main scope we had a problem when trying to click on address Leases tab we get an error with the following massage ( MMC cannot initilize the snap-in).
    We are running windows 2008 R2 ... and have may roles on this server:
    AD
    DHCP
    DNS
    and GPO

    Any suggestions.
    With best regards.

    Thursday, October 22, 2009 6:54 AM

All replies

  • Hi I have exactly the same thing as well. Any help would be appreciated. Am running sfc /scannow as directed by another post, however not really hopeful.

    cheers
    Friday, October 23, 2009 11:53 AM
  • Hi Adham,


    Can you be clear which version of windows server 2008 you are running ? and also check the below link

    http://windowsarchitecture.spaces.live.com/blog/cns!C8EE0FE9E055C129!239.entry




    sainath !analyze
    Saturday, October 24, 2009 2:05 AM
  • Try to copy the v2.0.50727 folder usually under C:\Windows\Microsoft.NET\Framework64\v2.0.50727 from and working system on to the broken system and that should fix your problem. (If you have a 32bit system the file name might be Framework32)
    MA
    Tuesday, November 16, 2010 11:12 PM
  • Copying the framework folders worked for me.  Thanks!
    Monday, January 31, 2011 10:25 PM
  • I tried this method and some security issue. doesnt allow me to paste the framework.

    any other solution for this ? thank you.

    Thursday, February 10, 2011 1:09 AM
  • @TSMSupport: What security issues, can you post the error message your getting. Are you logged in with Admin account and do you have write permissions to the destination folder? Also can you make sure your application is not using .NET framework while you are trying to override the files.


    MA
    • Proposed as answer by BK9999 Wednesday, January 1, 2014 4:52 PM
    • Unproposed as answer by BK9999 Wednesday, January 1, 2014 4:52 PM
    Thursday, February 17, 2011 3:42 PM