locked
Horizontal Scrollbar in a Metro ui Listview RRS feed

  • Question

  • Hi ,

    I'm building a Metro UI app and I'm populating dynamically data with the ListviewItem template.

    Everything is working good so far. My binding works , the autoadjust of the height and width of my listview columns works.

    So far so good.

    But when I run my app to the simulator I cannot see all of my screen. Of course tha vertical scroll of my list view is enabled but If I rotate clockwise the simulator in 90 degrees position I miss of course some of my display data and  I don't get the Horizontal Scroll bar from the listview.

    How can I enable the Horizontal Scroll bar if it doesn't fit in my screen ?

    Any ideas ?

    thank you

    zkar

    Thursday, October 11, 2012 1:00 PM

Answers

  • By default, HorizontalScrollMode is Disabled for ScrollViewers, including the one inside your ListView.  So you'll need to do both what ForInfo says (to see the scrollbar) and enable it to get what you're describing:

    <ListView ScrollViewer.HorizontalScrollBarVisibility="Auto" ScrollViewer.HorizontalScrollMode="Enabled" > ...

    Hope this helps,
    Matt 


    XAML SDET Lead : Input / DirectManipulation / Accessibility

    • Marked as answer by zakkar Monday, October 15, 2012 7:44 AM
    Thursday, October 11, 2012 6:26 PM

All replies

  • Does <ListView ScrollViewer.HorizontalScrollBarVisibility="Auto" ... work?
    Thursday, October 11, 2012 1:35 PM
  • By default, HorizontalScrollMode is Disabled for ScrollViewers, including the one inside your ListView.  So you'll need to do both what ForInfo says (to see the scrollbar) and enable it to get what you're describing:

    <ListView ScrollViewer.HorizontalScrollBarVisibility="Auto" ScrollViewer.HorizontalScrollMode="Enabled" > ...

    Hope this helps,
    Matt 


    XAML SDET Lead : Input / DirectManipulation / Accessibility

    • Marked as answer by zakkar Monday, October 15, 2012 7:44 AM
    Thursday, October 11, 2012 6:26 PM
  • Hi ,

    It worked

    thank you

    Monday, October 15, 2012 7:45 AM