Biztalk Deployment FrameWork to Deploy IIS RRS feed

  • Question

  • Hi,

    I am Deploying the virtual Directory in IIS so I can read the VDIR_UserName and VDIR_UserPass from Settings Generator xml file but I want to move this to installwizrad.xml so tat it can prompt me for USername and password so I have added the below code and deleted from settingsGenrator.xml file

        <PromptText>Enter a domain-qualified name for virtual directory(HTTP and SOAP) identities :</PromptText>
        <PromptText>Enter a Password for account specified :</PromptText>

    but when I deploy I get the error like vdir_username and VisrPassowrd is empty and it will not deploy it to IIS. How can I read the value form Installwizrad.xml?Do I have to add anything in btdfproj file?



    Monday, November 30, 2015 1:39 PM


  • Sujith,

    I am assuming you are referring to the username and password for the application pool, yes?

    Lets make sure we cover the basics. Looks like you did, but it doesn't hurt to confirm:

    1. Make sure you set the IncludeVirtualDirectories flag to True in the project file.
    2. VDIR_UserName and  VDIR_UserPass will become environment variables. When MSBUild launches it makes all environment variables available by turning them into properties. These will be used to create the application pool in IIS.
    3. In your .btdfproj file you will have something like this:


     <VDirList Include="*">







    Note that the username and password environment variables are going to be used as the identity of the app pool declared under VDirList.

    Please let me know if you are doing all of the above and it is still not working. Also, if you get an error, please cut ans paste it here so I can help you figure this out. If you follow the steps above, it will work.

    • Edited by Mauricio Feijo Monday, November 30, 2015 3:39 PM
    • Proposed as answer by Mauricio Feijo Monday, November 30, 2015 11:36 PM
    • Marked as answer by Angie Xu Monday, December 7, 2015 2:28 AM
    Monday, November 30, 2015 3:38 PM