none
HLK Failure with Microsoft-OneCore-Graphics-Tools-Package.cab RRS feed

  • Question

  • I've been trying to get the Microsoft-OneCore-Graphics-Tools-Package.cab to install properly.

    On my target system, I run dism /online /add-package /packagepath:C:\TEST\Microsoft-OneCore-Graphics-Tools-Package~31bf3856ad364e35~amd64~~.cab

    I verified that the package has been added by running dism /online /get-packages and it shows up properly as Microsoft-OneCore-Graphics-Tools-Package~31bf3856ad364e35~amd64~~.cab

    The problem is that when I run any tests it's needed for, it complains that it's not installed. 

    I noticed in the log file that the test is is looking for Microsoft-OneCore-Graphics-Tools-Package.cab but the HLK_GRFX_FOD.zip file has Microsoft-OneCore-Graphics-Tools-Package~31bf3856ad364e35~amd64~~.cab instead.

    <Error 
    File="" 
    Line="-1" 
    ErrCode="0x0" 
    ErrType="" 
    ErrorText="Error 0x00000000" 
    UserText="Error: Missing or mismatched required graphics support files. To resolve this error, please perform the following:
    On desktop, locate Microsoft-OneCore-Graphics-Tools-Package.cab and run &quot;dism /online /add-package /packagepath:&lt;path to package&gt;\Microsoft-OneCore-Graphics-Tools-Package.cab&quot;
    On mobile, locate Microsoft.Graphics.DXTools.spkg and run &quot;deployd -packages Microsoft.Graphics.DXTools.spkg -packageroot:&lt;path to package&gt;&quot;
    " CA="155134" LA="155582" >
    <Data>
    <WexTraceInfo ThreadId="512" ProcessId="3660" TimeStamp="43292631073" LogSessionId="1"/>
    </Data> <rti id="4003919981" />
    <ctx id="384048256" />
    </Error>


    Tuesday, June 5, 2018 7:57 PM

All replies

  • Hi,

    Can I check your Win10 os version ?

    This file 31bf3856ad364e35~amd64~~.cab is for Win10x64 1803 17134.

    So,I think your os is 1709 or older

    Best Regards,

    Weber Chang

    Wednesday, June 6, 2018 7:49 AM
  • Weber,

    Thanks for your reply. I can't believe I missed that. My Client system is indeed running Microsoft Windows [Version 10.0.16299.431] (1709). That explains it. I had run the wrong client system.

    Regards,

    John

    Wednesday, June 6, 2018 6:54 PM
  • How to find which cab is compatible with OS version?

    Thursday, September 20, 2018 9:22 PM