none
.net 4.0 setup hangs on xp sp3 RRS feed

  • Question

  • when I run .net 4.0 installer, it seems to exit or hang after extracting netfx_Extended.mzz

    log file in %temp% is the following

    [10/18/2010, 21:27:31] === Logging started: 2010/10/18 21:27:31 ===
    [10/18/2010, 21:27:31] Executable: C:\Documents and Settings\main\Desktop\dotNetFx40_Full_x86.exe v4.0.30319.1
    [10/18/2010, 21:27:31] --- logging level: standard ---
    [10/18/2010, 21:27:31] Successfully bound to the ClusApi.dll
    [10/18/2010, 21:27:31] Error 0x800706d9: Failed to open the current cluster
    [10/18/2010, 21:27:31] Cluster drive map: ''
    [10/18/2010, 21:27:31] Considering drive: 'A:\'...
    [10/18/2010, 21:27:32] Drive 'A:\' is rejected because of the unknown or unsuitable drive type
    [10/18/2010, 21:27:32] Considering drive: 'C:\'...
    [10/18/2010, 21:27:32] Considering drive: 'D:\'...
    [10/18/2010, 21:27:32] Drive 'D:\' is rejected because of the unknown or unsuitable drive type
    [10/18/2010, 21:27:32] Drive 'C:\' has been selected as the largest fixed drive
    [10/18/2010, 21:27:32] Error 0x80070032: Failed to decrypt the extract directory
    [10/18/2010, 21:27:32] Directory 'C:\e050f623f8abd64df4\' has been selected for file extraction
    [10/18/2010, 21:27:32] Extracting files to: C:\e050f623f8abd64df4\
    [10/18/2010, 21:27:47] Extraction took 14.593 seconds
    [10/18/2010, 21:27:47] Executing command line: 'C:\e050f623f8abd64df4\\Setup.exe   /x86'
    [10/18/2010, 21:28:19] Exiting with result code: 0x0
    [10/18/2010, 21:28:19] === Logging stopped: 2010/10/18 21:28:19 ===

    Similar thing happens whether I use web or standalone installer.  I have windows installer 4.5.  Have already tried the cleanup tool to fix and reinstall .net versions up to 3.5 previously there.  But after reaching netfx_Extended.mzz the installer window closes and no sign of a .net 4.0 installation.

    I'm a basic windows user but need .net 4.0 to run our patient booking software TM2, any advice appreciated.

    Monday, October 18, 2010 8:39 PM

Answers

All replies

  • Hi PDud,

     

    Thank you for your post.

     

    What is your OS version?

     

    Regarding information, I would recommend that you could try the following suggestions.

     

    Download .NET Framework 4 from the following link: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

    Extract installation file into your local hard disk.

    Please check whether your account has FULL permissions to access installer.

    Disable anti-virus, any security software or firewall.

    Run installer as Administrator.

    Reinstall .NET Framework 4 again.

     

    If you have any issues during installation, please check the following suggestions to collect installation log files.

    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install .NET Framework 4.0 Standalone installer
    - Collect the logs from "%temp%" folder
       Collect tool:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=e0da314f-6216-4a18-bc6b-7d29cf83af20&displaylang=en

    - Send vslogs.cab file to me (v-xugong@microsoft.com)
      Note: Please attach the link of this post in the mail.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Larcolais


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, October 20, 2010 3:29 AM
  • Had the same problem and tried unpacking, etc.

    Finally took the computer off the docking station.  Framework 4.0 then installed properly.

    Monday, March 26, 2012 1:33 PM