none
Visual Studio Emulator for Android OpenGL Error

    Question

  • I'm developing an app for Android using Xamarin.Forms and whenever I debug and use the Visual Studio emulator for android, I get this error:

    An OpenGL error has occured:

    Failed to connect to 169.254.76.233:3556!

    The emulator will now shutdown.

    Here is the link: http://i.imgur.com/CH2c8ej.png

    I ALWAYS get this error when the emulator has already ran the application once. I sometimes get it when I initially debug the app and the emulator opens. Any ideas? This emulator has been the least pain to get up and running save for this one annoying error I keep getting. But when it works, it works wonders. 

    Sunday, May 29, 2016 3:34 AM

All replies

  • Hi NMollaneda,

    Thanks for your post.

    Please try this following:

    1) Open an Admin Command Prompt and run the following commands

    • net localgroup administrators
    • net localgroup administrators LOCAL /delete
    • net localgroup administrators SERVICE /delete

    2) Open Device Manager and click on View -> Show Hidden Devices. Go down to Network Adapters and uninstall everything.  Then right click at the root of Device Manager and select Detect hardware changes to reinstall your network adapters.

    3) Uninstall Hyper-V

    4) Reboot

    5) Reinstall Hyper-V

    6) Attempt to run Virtual machine.

    Please also take a look at the following document about Troubleshooting the Visual Studio Emulator for Android

    https://msdn.microsoft.com/en-us/library/mt228282.aspx

    Best Regards,

    Lake Xiao


    Tuesday, May 31, 2016 2:16 AM
    Moderator
  • Have you installed Hamachi or similar software? If so, disable all adapters which are related to this software (Hamachi, vEthernet LogMeIn Hamachi). You can do this by going to Network and Sharing Center -> Change adapter settings. The emulator should work fine after that.
    • Proposed as answer by Alex254 Tuesday, February 21, 2017 1:57 PM
    Tuesday, July 19, 2016 8:04 AM
  • Have you installed Hamachi or similar software? If so, disable all adapters which are related to this software (Hamachi, vEthernet LogMeIn Hamachi). You can do this by going to Network and Sharing Center -> Change adapter settings. The emulator should work fine after that.
    Worked for me! Thx
    Tuesday, February 21, 2017 1:59 PM
  • Better still - and much simpler... Find your emulator's virtual machine in the Hyper-V Manager, open its settings (the VM must not be running) and look for external network adapters in the hardware list on the left side: you need to disconnect all that don't have access to the internet. Set one (I suspect it's better if it's the first one) to be connected to your main network adapter (the one that can access the net), and the rest as "not connected".

    Tuesday, April 10, 2018 1:39 PM