none
can't get data picker control working on my win7 64 bit laptop RRS feed

  • Question

  • I know this is a recurring question (according to the number of entries I found on Google), but none of them helped and I need to find a solution. 

    I run Win 7 64 bit and Excel 32 bit. I need mscomct2.ocx to run my macros. 

    I downloaded it from http://www.gmayor.com/Zips/MSCOMCT2.zip. I extracted mscomct2.ocx into c:\windows\sysWOW64\

    As admin, I executed C:\Windows\SysWOW64>regsvr32 c:\windows\sysWOW64\mscomct2.ocx

    but it returned error 0x8002801c

    What did I do wrong?

    Thank you

    Tuesday, May 14, 2019 10:11 AM

All replies

  • Did you run the command prompt as Administrator?
    Tuesday, May 14, 2019 8:45 PM
    Moderator
  • Yes, I did launch cmd.exe as an Admin.
    Wednesday, May 15, 2019 10:45 AM
  • In cmd as Admin try navigating to SysWOW64. "cd.." to go back a level and when in windows\"cd syswow64"

    then simply: "regsvr32 mxcomct2.ocx"

    (the quotes only for clarity, don't include them)

    Might need to wait a few seconds but should get a succeeded message


    Wednesday, May 15, 2019 1:59 PM
    Moderator
  • 

    Same error, sorry!


    Wednesday, May 15, 2019 2:16 PM
  • The OCX is stored at the right place.

    Wednesday, May 15, 2019 2:18 PM
  • One question: I work for Eli Lilly in Geneva Switzerland. Can it be that I have limited rights (even as Admin) to register stuff? Can you tweak the Adminiistrators group so that members cannot register anymore?

    We have Win 7 64 bits and Office 32 bits, this is why I believe I can still use mscomct2.ocx

    Wednesday, May 15, 2019 2:22 PM
  • Do I have the right file?

    Wednesday, May 15, 2019 2:26 PM
  • Looks like you've done everything right, in particular as admin with the file in sysWOW64, frustrating I know!

    There was a security update for several of the VB6 runtime dll & ocx files roughly 10 years ago but I think you've got the right version. I downloaded it from same source, same specs as your screenshot, and registered it in a Win7/64. As you can see (below no problem doing exact same as you. 

    A quick search of regsvr32 with your error code gives different solutions, ranging from permissions to disabling an item in msconfig/startup, maybe look into what seems most likely for your scenario. And report back, good luck!

    Wednesday, May 15, 2019 3:26 PM
    Moderator
  • ok i am going to ask someone from IT to run this for me on my laptop, with their credentials having full power, and see if they can get a better result. I'll let you know.. Thank you for your help so far!
    Saturday, May 25, 2019 7:14 AM