locked
SSO in MOSS - InfoPath Data Connection to a WCF Web Service RRS feed

  • Question

  • An SSO entity needs to connect to a WCF Web Svc hosted in the same SP farm, which goes out to a SQL DB.

    I have configured the SSO. I see that the SSO Admin A/C created a DB and added the Ent. App Def with the Credentials specified in the DB. SO I believe the setup is right.

    However, when I use this in a UDCX file's authentication node, to be consumed by an IP 2007 Form Template, I get "Error accessing the Data Source".

    I am trying to deploy IP Form templates with Domain Security, rather than Full Trust (Admin Approved). And this template uses WCF Web Svc to receive and submit data to a SQL DB, whose credentials are specified in the conn string of the Web Svc.

    Here is the UDC's Auth node:

    <udc:Authentication>

    <udc:SSO AppId="wcfsvc" CredentialType="NTLM" />

    </udc:Authentication>

    Any pointers would be very helpful and will be greatly appreciated.

    Monday, March 14, 2011 2:57 PM

Answers

  • Hi,

    Thanks to share your post.

    For the issue, my suggestion is that you should try to reset the UDC authentication block:

    <udc:Authentication>
           <udc:UseExplicit CredentialType="NTLM">
                  <udc:UserId>myusername</udc:UserId>
                  <udc:Password>mypassword</udc:Password>
           </udc:UseExplicit>
    </udc:Authentication>

    And if the issue still exists, go to SharePoint Central administration --> Application Management --> Authentication Providers. Then select the default zone. Make sure the right Web Application is selected on the top of the page. Clear the checkbox for the anonymous access (When you are using Forms Server with MOSS the site security is not applied to the underlying services. It means even if your MOSS website requires authentication, if Provider is anonymous enabled forms services uses anonymous login for the external access, because it looks at the provider, not the site that is hosting the form).

    And the followed two articles are about the resolution to the same issue:

    http://urenjoy.blogspot.com/2009/03/error-occurred-accessing-data-source.html.

    http://sharenotes.wordpress.com/2008/03/06/infopath-cannot-connect-to-a-data-source-when-viewed-in-browser-cross-domain-issues-universal-data-connection/.

    Hope this could help you!

    Leo

    • Marked as answer by Emir Liu Thursday, March 17, 2011 7:58 AM
    Tuesday, March 15, 2011 9:48 AM