locked
Setting android-sdk location in MSBuild? RRS feed

  • Question

  • User153754 posted

    I'm trying to setup Jenkins to produce builds of a VS 2015 Xamarin Android app, but I'm running into this problem:

    https://forums.xamarin.com/discussion/45210/enable-proguard-error-c-program-files-access-is-denied

    Creating the symlink and setting the Android SDK location in the Visual Studio Xamarin settings works great, but when I try and run the build through Jenkins, which uses an MSBuild batch command, I'm back to getting the "PROGUARD : error : C:\Program Files (Access is denied)" error. Is there any reason the Android SDK location setting would not be picked up by MSBuild or is there some other way I can set the configuration for Xamarin so that it does work with MSBuild?

    Tuesday, September 8, 2015 2:09 PM

All replies

  • User319010 posted

    Any Solution to this?

    Wednesday, July 5, 2017 6:43 AM
  • User153754 posted

    I fixed it by linking the Android SDK to C:\android-sdk. The Program Files path is too long for proguard, that's why it's erroring out.

    Wednesday, July 5, 2017 3:30 PM