locked
TF400908: The account page you are trying to view does not exist or you do not have access to it. RRS feed

  • Question

  • Hello,

    Since today, I am having trouble accessing my tfs preview account from visual studio 2012. It was working fine yesterday and I did not do any modifications to any users rights or groups (actually, i'm the only on in there).

    When I try to login in visual studio 2012, I get

    TF400908: The account page you are trying to view does not exist or you do not have access to it.

    Thanks!


    Jonathan Co

    Tuesday, October 16, 2012 12:49 AM

Answers

  • From the service BLOG:

    Intermittent connectivity issues - 10/16/12 - Resolved

    By Team Foundation Service Team

    Final Update – We identified the issue and have rolled a fix.   We’ve confirmed the issue has been resolved. If you are still seeing issues you may want to restart Visual Studio client to clear your cache.

    Reach out via our support forum (here) if this does not resolve your specific issues.

    --------------------------------------

    This is not a mandatory part of the cache clear mentioned above, but may be helpful if a simple restart of VS does not fix this for you. Please note, the first part assumes you are using Internet Explorer. If that is not your primary browser, please use the functionality in your browser of choice to delete all temp internet files and cookies. 

    FIX 1: Delete TF Service cookie
     

    1. Close all browser instances, Live Messenger instances, SkyDrive, Live Mesh, or anything else that is signed in with your Microsoft account (formerly "Live ID").

    2. Open Internet Explorer and visit LIVE.COM. Click ‘Sign Out’ in the top-right corner.

    3. Use Internet Explorer to delete all your Temporary Internet File and Cookies. If you do not want to delete ALL your cookies, then…

        a.    Determine the folder where your cookies are stored.

        b.    Open File Explorer to that folder

        c.    Search for all files with cookie & tfspreview in the name. Delete any you find. NOTE: you may need to enable display of hidden files and folders in File Explorer.

     

     

     

     

    FIX 2: Rename the TFS \ VS Cache

     

    1. Close all open instances of Visual Studio (**IMPORTANT**). Don't forget about any Power Tools, build alerts, etc.

    2. Run the following from a .CMD in an elevated Command Prompt.

     

    SET AppDataTF=%USERPROFILE%\Local Settings\Application Data\Microsoft\Team Foundation

    SET AppDataVS=%APPDATA%\Microsoft\VisualStudio

     

    IF EXIST "%AppDataTF%\1.0\Cache" MOVE "%AppDataTF%\1.0\Cache" "%AppDataTF%\1.0\Cache.OLD"

    IF EXIST "%AppDataTF%\2.0\Cache" MOVE "%AppDataTF%\2.0\Cache" "%AppDataTF%\2.0\Cache.OLD"

    IF EXIST "%AppDataTF%\3.0\Cache" MOVE "%AppDataTF%\3.0\Cache" "%AppDataTF%\3.0\Cache.OLD"

    IF EXIST "%AppDataTF%\4.0\Cache" MOVE "%AppDataTF%\4.0\Cache" "%AppDataTF%\4.0\Cache.OLD"

     

    IF EXIST "%AppDataVS%\8.0\Team Explorer" MOVE "%AppDataVS%\8.0\Team Explorer" "%AppDataVS%\8.0\Team Explorer.OLD"

    IF EXIST "%AppDataVS%\9.0\Team Explorer" MOVE "%AppDataVS%\9.0\Team Explorer" "%AppDataVS%\9.0\Team Explorer.OLD"

    IF EXIST "%AppDataVS%\10.0\Team Explorer" MOVE "%AppDataVS%\10.0\Team Explorer" "%AppDataVS%\10.0\Team Explorer.OLD"

    IF EXIST "%AppDataVS%\11.0\Team Explorer" MOVE "%AppDataVS%\11.0\Team Explorer" "%AppDataVS%\11.0\Team Explorer.OLD"


    Trevor Hancock (Microsoft)
    Please remember to "Mark As Answer" the replies that help.

    Wednesday, October 17, 2012 2:03 PM
    Moderator

All replies

  • I'm having the same problem. Glad I'm not the only one but I am worried!
    Tuesday, October 16, 2012 1:46 AM
  • Broken here, too. Was working as late as last week. Not related to firewall, etc.


    • Edited by deesnider Tuesday, October 16, 2012 2:26 AM
    Tuesday, October 16, 2012 2:21 AM
  • Same issue here. I can get into the site and see my projects in TFS fine. But can't log in from Visual Studio. Anyone know what's going on? Wasting lot of hours on this. Rethinking TFS online.

    http://blog.camantrix.com/sharepoint

    Tuesday, October 16, 2012 2:34 AM
  • Same error here as well. It just stopped working all of a sudden. No changes made. 
    Tuesday, October 16, 2012 3:56 AM
  • Hi Jonathan,

    Thank you for your post.

    I test the issue in my side, i can connect to TFSPreview with Visual Studio Team Explorer 2012 successfully without experience any problem.

    Hope you can provide following information to help narrow down the issue:
    1. Can you access your TFSPreview site via IE browser?
    2. Try to clear IE browser history include cookies, then connect TFSPreview via VS 2012 again, does the issue still exist?
    3. If the issue still exist, please email me(email to v-liliw@microsoft.com) your email address?

    If anything is unclear, please free feel to let me know.

    Regards,


    Lily Wu [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, October 16, 2012 5:37 AM
    Moderator
  • Hi,

    I am also getting the same error since morning.

    TF400908: The account page you are trying to view does not exist or you do not have access to it. I am using it from VS2012.

    1. I can access my TFSPreview account from browser

    2. Clearing cache, cookies did not help.

    Regards,

    Aamir


    • Edited by Aamir Arif Tuesday, October 16, 2012 6:25 AM
    Tuesday, October 16, 2012 6:24 AM
  • Hi Lily

    This error come to me after I install Visual Studio Extensions for Windows Library for JavaScript 1.0.9200.20512.

    After I uninstall that extension connection work OK.

    Regards

    Markku

    Tuesday, October 16, 2012 8:04 AM
  • I'm having the same problem.

    • I can access the project fine from my browser
    • Neither Visual Studio, nor Build Notifications can connect
    • Clearing cookies does not help
    • I do not have the Visual Studio Extensions for Windows Library for JavaScript installed.
    Tuesday, October 16, 2012 8:42 AM
  • Same problem here,

    I can access the project fine from my browser, but within Vs I get this

    Tuesday, October 16, 2012 9:39 AM
  • I'm having the same problem - just noticed it this morning. Visual studio 2010
    Tuesday, October 16, 2012 12:29 PM
  • I am also having this problem. I've tried two accounts with correct privileges. Please fix!
    Tuesday, October 16, 2012 1:22 PM
  • I am having this same issue... 

    Tuesday, October 16, 2012 1:34 PM
  • Alas I am in the same boat.

    It started happening for me late last night US EDT.

    DANGER, WILL ROBINSON DANGER!!!

    Tuesday, October 16, 2012 1:42 PM
  • Same issue here as well I have attempted to uninstall the JavaScript libraries as suggested in another post in this thread but that hasn't changed anything.  Still the same error being reported in VS2012 and can access the web portal no problem.

    Let us know what is going on soon please!

    Thanks

    Chris

    EDIT
    -----------------------------------------------------------------------

    I installed the power tools for VS2012 and that apparently solved it for me if anyone else wants to try it :)

    Tuesday, October 16, 2012 2:40 PM
  • the Problem is the same, what to do? sit on one ip. but only one person has stopped working. and from any account. What do we do?
    • Edited by Alekseevkm Tuesday, October 16, 2012 3:24 PM
    Tuesday, October 16, 2012 3:21 PM
  • I just tried something and it worked.

    Log into TFSPreview browser, and then go to settings. Click on your email id, and then on permissions, set everything to "ALLOW" instead of "INHERITED ALLOW".

    This worked for me. I hope it works for you too.

    Epa Bizimana.

    • Proposed as answer by Epa Bizimana Tuesday, October 16, 2012 3:26 PM
    Tuesday, October 16, 2012 3:26 PM
  • I installed the power tools for VS2012 and that apparently solved it for me if anyone else wants to try it :)

    Thank you! That fixed the problem for me too! (Seems to be a solution, at least temporarily)

    The weird thing with this error is that it only occured on my tablet (on which the login worked just 8 hours ago and I didn't install or change anything). On my PC I could login without a problem. Same IP, same version.


    Tuesday, October 16, 2012 3:29 PM
  • Yes, there will update this section of the Tool for VS 2012 and after that it worked!
    Tuesday, October 16, 2012 4:17 PM
  • I too can confirm that to be an issue for me too.  I tried installing vs2012 power tools but didn't make any difference.  Can someone from MS actually acknowledge the problem, there is clearly an issue when heaps of people at once have the same problem from around the world.

    BTW, like others, I'm questioning Microsoft ability for run this platform since it has been up in "preview" stage for more than a year now.

    EDIT:

    Ok, I performed quite a bit of testing and found the following solutions (note it may be 1 or all of the below).

    1.  Install TFS 2012 Power Tools

    2.  Remove Extensions for Javascript update

    3.  Perform the "ALLOW" instead of "INHERITED ALLOW" as suggested above by Epa.

    Tuesday, October 16, 2012 7:10 PM
  • Please check the service status page when you have issues like this: http://tfspreview.com/en-us/support/current-service-status/. There is currently an issue under investigation Oct 16 2012  21:45 UTC.

    Trevor Hancock (Microsoft)
    Please remember to "Mark As Answer" the replies that help.


    Tuesday, October 16, 2012 9:45 PM
    Moderator
  • From the service BLOG:

    Intermittent connectivity issues - 10/16/12 - Resolved

    By Team Foundation Service Team

    Final Update – We identified the issue and have rolled a fix.   We’ve confirmed the issue has been resolved. If you are still seeing issues you may want to restart Visual Studio client to clear your cache.

    Reach out via our support forum (here) if this does not resolve your specific issues.

    --------------------------------------

    This is not a mandatory part of the cache clear mentioned above, but may be helpful if a simple restart of VS does not fix this for you. Please note, the first part assumes you are using Internet Explorer. If that is not your primary browser, please use the functionality in your browser of choice to delete all temp internet files and cookies. 

    FIX 1: Delete TF Service cookie
     

    1. Close all browser instances, Live Messenger instances, SkyDrive, Live Mesh, or anything else that is signed in with your Microsoft account (formerly "Live ID").

    2. Open Internet Explorer and visit LIVE.COM. Click ‘Sign Out’ in the top-right corner.

    3. Use Internet Explorer to delete all your Temporary Internet File and Cookies. If you do not want to delete ALL your cookies, then…

        a.    Determine the folder where your cookies are stored.

        b.    Open File Explorer to that folder

        c.    Search for all files with cookie & tfspreview in the name. Delete any you find. NOTE: you may need to enable display of hidden files and folders in File Explorer.

     

     

     

     

    FIX 2: Rename the TFS \ VS Cache

     

    1. Close all open instances of Visual Studio (**IMPORTANT**). Don't forget about any Power Tools, build alerts, etc.

    2. Run the following from a .CMD in an elevated Command Prompt.

     

    SET AppDataTF=%USERPROFILE%\Local Settings\Application Data\Microsoft\Team Foundation

    SET AppDataVS=%APPDATA%\Microsoft\VisualStudio

     

    IF EXIST "%AppDataTF%\1.0\Cache" MOVE "%AppDataTF%\1.0\Cache" "%AppDataTF%\1.0\Cache.OLD"

    IF EXIST "%AppDataTF%\2.0\Cache" MOVE "%AppDataTF%\2.0\Cache" "%AppDataTF%\2.0\Cache.OLD"

    IF EXIST "%AppDataTF%\3.0\Cache" MOVE "%AppDataTF%\3.0\Cache" "%AppDataTF%\3.0\Cache.OLD"

    IF EXIST "%AppDataTF%\4.0\Cache" MOVE "%AppDataTF%\4.0\Cache" "%AppDataTF%\4.0\Cache.OLD"

     

    IF EXIST "%AppDataVS%\8.0\Team Explorer" MOVE "%AppDataVS%\8.0\Team Explorer" "%AppDataVS%\8.0\Team Explorer.OLD"

    IF EXIST "%AppDataVS%\9.0\Team Explorer" MOVE "%AppDataVS%\9.0\Team Explorer" "%AppDataVS%\9.0\Team Explorer.OLD"

    IF EXIST "%AppDataVS%\10.0\Team Explorer" MOVE "%AppDataVS%\10.0\Team Explorer" "%AppDataVS%\10.0\Team Explorer.OLD"

    IF EXIST "%AppDataVS%\11.0\Team Explorer" MOVE "%AppDataVS%\11.0\Team Explorer" "%AppDataVS%\11.0\Team Explorer.OLD"


    Trevor Hancock (Microsoft)
    Please remember to "Mark As Answer" the replies that help.

    Wednesday, October 17, 2012 2:03 PM
    Moderator
  • It started working late last night. Thanks!

    Jonathan Co

    Wednesday, October 17, 2012 5:24 PM