none
Failed to start the database service MSSQL$OfficeServers

    Question

  • Hello,

     

    I have installed Windows Search Server.

    When I install, I have an error "Failed to start the database service MSSQL$OfficeServers".

     

    I have not solution. Anyone ?

     

    Thanks.

    Christophe.

    Wednesday, November 14, 2007 3:12 PM

All replies

  • Can you manually start this SQL Server instance?

    Friday, November 16, 2007 1:14 PM
  •  

    Same error on clean install (Win2k3 server, search server express)

     

    add/remove contains:

    Microsfot SQL Server VSS Writer

    Microsoft SQL Server Setup Support Files (English)

    Microsoft SQL Server Native Client

     

    which one to add/remove....?

    Monday, February 25, 2008 4:03 PM
  •  

    You did not correctly installed SQL Server Express. I suggest that you manually install it again.
    Tuesday, February 26, 2008 3:44 AM
  •  

    I don't think this is a SQL Server Express installation issue.  I have the same problem, but SQLSExp is setup fine on my machine.  I did see a service running -- called MSSQL$SHAREPOINT.  Could this be the service that SearchSExpress is looking for?  If so, how do we change the connection string for the "SharePoint Products and Technologies Configuration Wizard"?

     

    I have another post today from this problem.  Sorry I didn't look further before I posted. 

    Monday, April 14, 2008 4:50 PM
  • This blog link work for me to sort out the error.


    Blog Link
    Regards Deepak Kumar Rai Enhanced Software Solution India
    Monday, July 06, 2009 11:09 AM
  • << How to Become a Microsoft MVP | Install MOSS 2007 or Project Server 2007 on Windows Server 2008 R2 >> Failed to start the database service MSSQL$OfficeServers Categories: Sharepoint Posted by yeejie on 10/27/2009 8:00 PM | Comments (0) When you launched “SharePoint Products and Technologies Configuration Wizard” and got into this error: Failed to start the database service MSSQL$OfficeServers. Repair this product by selecting it from the Add/Remove Programs menu. Here’s the solution: Go to “regedit”, browse thru “HKLM_Local_Machine/Software/Microsoft/Shared Tools/Web Server Extensions/12.0/WSS/”. Then change the value of attribute named “ServerRole” from SINGLESERVER to APPLICATION.
    • Proposed as answer by Mina Samy Thursday, August 05, 2010 8:50 AM
    Sunday, January 24, 2010 12:51 PM
  • the following solution worked for me:

    http://www.yeejie.com/blog/post/2009/10/27/Failed-to-start-the-database-service-MSSQL24OfficeServers.aspx

    d3v
    Monday, February 01, 2010 6:23 PM
  • Thanks Ayman.  This got me through the configuration wizard with no errors.

    Greg
    Wednesday, February 10, 2010 4:13 PM
  • Thank  you Ayman. You helped me.
    Tuesday, February 23, 2010 10:02 AM
  • That worked!  Fantastic!
    Wednesday, April 28, 2010 6:09 PM
  • Thanks Ayman !

    The trick worked :)

    Friday, April 30, 2010 7:30 PM
  • Because the above link is not working anymore here is the solution:

    Go to “regedit”, browse thru “HKLM_Local_Machine/Software/Microsoft/Shared Tools/Web Server Extensions/12.0/WSS/”. Then change the value of attribute named “ServerRole” from SINGLESERVER to APPLICATION.

    Friday, May 21, 2010 1:01 AM
  • THANK YOU Jolly_man! Fixed it perfectly.

    Now wasnt that easier then posting a link in the first place??

    Thursday, June 03, 2010 3:49 AM
  • Thanks Ayman it is realy work
    Tuesday, June 08, 2010 12:33 PM
  • Thanks Ayman, it really did work.  Unfortunately I wanted the single server option having selected BASIC from the Sharepoint install menu.  And now the only option I have is to set up a farm or join an existing farm.  I am trying to put together a demo model but get frustrated with every move I make.

    In the Sharepoint config menu I tried pointing the farm SQL server to the Sharepoint server but that did not work.  I guess I just start all over again for about the 10th time.

    Brian

    Monday, July 05, 2010 6:03 PM
  • Sorry Ayman, I just realized I am in a SP Search forum.  I am using SP 2007 so my response may not have been appropriate.  Sorry about that.

    Brian

    Monday, July 05, 2010 6:10 PM
  • Thanks ayman, it worked for  me too.
    Tuesday, February 15, 2011 11:01 AM
  • Worked for me too, great! Thanks!
    Friday, March 04, 2011 9:01 AM
  • Regarding the answers provided by deepak and ayman: Do they work long term or are there any problems occuring by changing the registry? I mean changing the registry might not be the recommended solution by Microsoft, isn't it?

    I feel a little bit uncomfortable applying this in my customers environment...

    thanks in advance


    Andreas Glaser
    SharePoint Tutorial
    Install SharePoint
    SharePoint Certification
    Monday, May 23, 2011 4:35 PM
  • I had the same problem here.  I did change from SINGLESERVER to APPLICATION just so SQL 2005 would install.  But before configuration of SP Server 2007, i had to switch back to single server for it to work appropriately.  I to was trying to creat a basic single server for demo purposes on oracle Vbox.  thanks for the tip it was helpful.  spend my whole weekend on this

    Saturday, April 14, 2012 8:23 PM
  • I really appreciate......Thanks @ Jolly_man
    Avatar of Jolly_man

    Jolly_man

    CAVIROM

    Partner

    5 Points 1 0 0
    Recent Achievements
    First Forums Reply
    Thursday, May 24, 2012 9:43 AM
  • Same Problem: "Configuration Failed..."

    But my registry in Windows Server 2008 doesn't have the same structure.

    See photos below. I'm stumped
    Most grateful for anyone's help!

    Sunday, June 10, 2012 3:23 PM
  • Never Mind...I found the correct registry key and now I'm advancing in the Configuration.
    Thanks for everyone's valuable input.

    Great thread.

    Sunday, June 10, 2012 3:52 PM
  • I've gotten past that screen,
    but now I'm stuck with an error message when I try to establish the configuration database.

    Also the dialogue box refers to "server farm"; However, the entire installation is on a single server, a machine called "sharepoint".
    Very confusing!

    Thanks for helping me get this ironed out!

    Sunday, June 10, 2012 4:18 PM
  • Thanks man its works.... :)
    Saturday, May 23, 2015 10:53 PM
  • nice dude.... but in Windows 8.1 the directory is HKLM_Local_Machine/Software/Microsoft/Shared Tools/Web Server Extensions/4.0/WSS/ please watch it...
    • Edited by Angoor Saturday, May 23, 2015 10:56 PM
    Saturday, May 23, 2015 10:55 PM