locked
Access Denied in FX2 for multiple apps

    Question

  • I had the FX2 working until a few hours ago. I added a new metro app in the privileged section in the wizard and now nothing works (not even the sample custom app). I tried several things. Just to name a few:

    1. Deleting the driver and starting over. I don't think that affects metadata registration, though.

    2. Deleting the device from Devices. I'm not sure what that does, but I don't think it does much more than turning off the device.

    3. Starting over with the default version of the metadata. Importing that didn't fix the sample metro app.

    4. Going over the inf file (which should be working anyway, since the sample app used to work.

    5. Restarting after each step, just to make sure everything was refreshed.

    6. Playing around with the sample desktop app. That works perfectly ok, so it must be a privileges issue.

    7. Confirming capabilities in both the sample app and my app. Both seem to be ok (reading: <DeviceCapability Name="573E8C73-0CB4-4471-A1BF-FAB26C31D384" />)

    8. Checking with the Device Enumeration Sample, the device is there (along with 2 others, not enabled) and the GUID in the previous step is correct.

    9. Tried to find where the privilege app information is stored (I'm assuming in the Registry), but couldn't find it.

    Debugging this stuff is really really hard. Is there any way to check which apps have access to a device (correct privileges) or to completely delete that information to start over? Is where this associations are stored public information so I can check it manually?

    Thanks,

    J

    Thursday, March 08, 2012 5:03 PM

Answers

  • I found out there's several dozen copies of the metadata files here: C:\ProgramData\Microsoft\Windows\DeviceMetadataStore\en-US. Removing the device from the Device Manager, then removing from here, then restarting, then reinstalling the driver, then restarting (forced) then running the metadata wizard, then restarting fixed the issue :).
    • Marked as answer by Joaquin Jares Thursday, March 08, 2012 8:29 PM
    Thursday, March 08, 2012 8:18 PM