locked
SPD Workflow Pause hangs but doesn't resume RRS feed

  • Question

  • I have a single Microsoft Office SharePoint Server 2007, recently updated with SP2, and a back-end SQL server. I have used SharePoint Designer to create a workflow which has a step in it that uses the "Pause For" action. When run against a list, the workflow gets to the pause statement but seems to just hang, and not resume. So on the list itself, it says the workflow is "In Progress".

    Anyone with suggestions???


    A Lambert
    • Edited by Mike Walsh FIN Friday, March 11, 2011 11:10 AM MOSS 2007 is default include by all means in text but it is not needed in title. Title re-writte. Original very jumpy.
    Friday, March 11, 2011 10:31 AM

Answers

All replies

  • On your SharePoint Server go into Start > Control Panel > Administrative Tools > Services.  Make sure that the Windows SharePoint Services Timer Job is "Started".

    *Also please note that for example if you put in an action that says "Pause for 1 minute" it may take more than one minute.  This timer job actually runs every 5 minutes (by default installation - can be adjusted for longer, but I believe 5 minutes is the most often you can set it to run).  So a 1 minute pause could take longer than expected.

    Friday, March 11, 2011 1:25 PM
  • Yes The Timer service is running...I've even tried restarting it. At the moment the "Pause For" is set at 10minutes but doesn't resume. I've also checked Timer settings which is set to 1min....so the Pause should resume after 11minutes?!
    A Lambert
    Friday, March 11, 2011 1:29 PM
  • Interesting..... Do you happen to know what version of asp.net you're running?  Do you have service pack 1?  I'm asking because I saw this here which sounds very similar to your problem:

    http://social.msdn.microsoft.com/Forums/en-US/sharepointworkflow/thread/b7524fd7-8616-474c-9a0b-6f69d86c4eff/

    Friday, March 11, 2011 1:46 PM
  • Hi.....when we installed SP2 we did install the .Net 3.51 update.....so I think the system is up to date.
    A Lambert
    Friday, March 11, 2011 2:43 PM
  • Friday, March 11, 2011 2:57 PM