none
Loading ActiveX control takes long time on some machines RRS feed

  • Question

  • We are having a partner that develops a .Net desktop application, and is using our ActiveX control.

    On the client machine it takes very long time to load the ActiveX control (~6 seconds). The partner reports that it hangs at this location:

    System.Windows.Forms.AxHost.CreateWithLicense(String, Guid)

    What could cause this delay and is there a work-around?

    I got this information on the problematic machine:
    HP Elitebook x360 830 G6 with 16GB RAM, 512GB SSD, i7-8665U processor.
    OS : Windows 10.

    Monday, November 25, 2019 7:07 AM

All replies

  • Hi Sanctus79,

    Thank you for posting here.

    Since this thread is related to ActiveX, we don't provide support for that.

    I suggest you can ask this question in ActiveX Forum.

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; Therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

    The Visual C# forum discusses and asks questions about the C# programming language, IDE, libraries, samples, and tools.

    Best Regards,

    Timon


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 26, 2019 8:19 AM