locked
Remove packages from the Tools Options Page (Isolated Shell VS2010) RRS feed

  • Question

  • I have an Isolated Shell application VS2010. I try to remove the packages (Source Control, Text Editor, Debugger, HTML Deisgner…) from the Tools Options Page. I uncommented the packages in the .pkgundef file but they are still displayed in the Option dialog with the “An error occurred loading this property page” message.

    Thanks

    Stephane

    Wednesday, December 8, 2010 6:16 PM

Answers

  • Hi Stephane,

    To remove unwanted pages from the Tools.Options dialog, you just need to list them in your .pkgundef file. For example, if you add the following to your .pkgundef, it will remove the International page. I don't think the keys are published, so you'll need to fish around in the registry for the ones you want.

       [$RootKey$\AutomationProperties\Environment\International]

    Sincerely,


    Ed Dore
    Thursday, December 9, 2010 4:15 AM

All replies

  • Hi Stephane,

    To remove unwanted pages from the Tools.Options dialog, you just need to list them in your .pkgundef file. For example, if you add the following to your .pkgundef, it will remove the International page. I don't think the keys are published, so you'll need to fish around in the registry for the ones you want.

       [$RootKey$\AutomationProperties\Environment\International]

    Sincerely,


    Ed Dore
    Thursday, December 9, 2010 4:15 AM
  • Hi Stephane,

     

    Is it resolved?

    Best Regards,

    Ziwei Chen

     

     


    Ziwei Chen [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, December 16, 2010 9:21 AM