locked
Grrr... Test Agent trying to connect to unknown Test Controller RRS feed

  • Question

  • My Test Controller is named DSHSEXECA601136.  Firewall is off.  I state in the Config to connect to DSHSEXECA601136:6901.

    What does it do?  It tries to connect to a host at 166.78.162.237?  WTH is that, it isn't even on our network?

    I, 2013/11/13, 11:52:12.430, AgentConfiguration: Found agent is not configured on any controller.
    I, 2013/11/13, 11:52:12.430, Getting information about controller: DSHSEXECA601136:6901.
    I, 2013/11/13, 11:52:12.430, Creating Channel
    I, 2013/11/13, 11:52:12.664, CreateControllerObject : ControllerVersion : 11.0
    I, 2013/11/13, 11:52:55.144, CreateControllerObject: attempt 0, System.Net.Sockets.SocketException (0x80004005): A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 166.78.162.237:6901

    Actually, it doesn't matter what I put in there for Test Controller... it ALWAYS tries to connect to 166.78.162.237:6901.  Even if I put my IP in there... 147.XX.XXX.XXX:6901

    Has anyone ever seen this behavior before?

    Friday, February 7, 2014 10:19 PM

Answers

  • Ah yes.  As usual it was user error (Me).

    I previously had a local site called toolbox.net and I had listed it in the hosts file as localhost.  I worked with a MSFT Rep, and while trying something else, I noticed I still had this left over artifact.  I removed it and everything started working. 

    • Marked as answer by Amanda Zhu Monday, February 17, 2014 1:48 AM
    Friday, February 14, 2014 4:51 PM

All replies

  • Here is some added information.  From the eventvwr, I see this...

    (TestAgenConfigUI.exe, PID 3280, Thread 3) KnownExecutionKeys.GetRemoteControllerUri: machineName is null or empty.

    Which is weird since I specifically add it in there.

    Monday, February 10, 2014 7:54 PM
  • Hi,

    I assume that your test controller is configured for load testing rather than connected to TFS Team Project Collection.

    It seems that the date in the test agent configure log is 2013/11/13, but the date in Event Viewer is 2014/2/10. Please make sure that you check the correct configuration log.

    Note that when we configure test agent, we need to type the name of test controller machine. Please make sure DSHSEXECA601136 is the name of the machine with test controller.

    Whether the test agent was registered to a test controller before?

    If you plan to run your test controllers and test agents on machines that are in a work group and not in a domain, or machines that run in different domains that do not have a two-way trust relationship, you must follow these steps as part of your installation process:

    On each computer where you will install a test controller or a test agent, create a local user account that is a member of the Administrators group. Use the same account and password on each machine.

    Use this user account for your test controllers when you install and configure them.

    Add this account to the TeamTestAgentService group on the test controller machine.

    Install and configure your test agents using this same account.

    Reference:

    Setting Up Test Controllers and Test Agents to Manage Tests with Visual Studio

    In order to research the issue, please post detailed configuration log of test agent here.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, February 11, 2014 5:40 AM
  • Hi,

    Any update?

    Whether my suggestions can help you?

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, February 14, 2014 8:46 AM
  • Ah yes.  As usual it was user error (Me).

    I previously had a local site called toolbox.net and I had listed it in the hosts file as localhost.  I worked with a MSFT Rep, and while trying something else, I noticed I still had this left over artifact.  I removed it and everything started working. 

    • Marked as answer by Amanda Zhu Monday, February 17, 2014 1:48 AM
    Friday, February 14, 2014 4:51 PM