SharePoint 2013 - Usage report - Empty RRS feed

  • Question

  • Hi,

    Do I need to set anything to let the reports being produced?

    My usage report has all zeros but I know the users are on.

    Thank you,


    Tuesday, February 28, 2017 10:19 AM

All replies

  • Hi,

    Can you try going into:

    1. Central Admin.
    2. Monitoring.
    3. Configure usage and health data collection.
    4. Check that Enable usage data collection and check that some events are being logged.

    Kind regards, Kev

    Tuesday, February 28, 2017 10:28 AM
  • It might also be worth looking at this


    Kind regards, Kev

    Tuesday, February 28, 2017 11:14 AM
  • Hi DevDiver,

    There are some reason which will lead to the usage report empty:

    1. permission for the database Wss_logging as described in this article:

    2. No Crawls: Actual data is processed during crawling. So if there is no crawler scheduled for content sources or there is a problem with the crawlers no actual data is processes.

    3. Named Users: Only queries and interaction done by “normal” named users are captured. If you access SharePoint using an administrative account you queries etc. would not be showmen in the reports.

    More information:

    SharePoint 2013 empty Usage and Health data report


    Best Regards

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Wednesday, March 1, 2017 6:34 AM
  • To configure usage report rather to get empty report, we need to follow below steps:
    Login to SharePoint Administrator site and verify by generating new reports is configured
    If usage report result is empty, we need to configure usage report.
    We need to create a login in sql Server and give that user as db_owner permission for the database Wss_logging (where all reports and usage history will get store)
    Once the user login is created, now to assign the same:
    Go to Central Admin, click on monitoring from left side quick launch and select configure usage and health data collection under reporting: 
     • Here click on enable usage data collection and select all event to log from radio box and down the page we need to health data collection.
    Next to the option select your SQL authentication which you have created with DB owner permission.
    It will resolve your solutions.

    Regards, Prashant Please click the 'Mark as Answer' if this post solves your problem or "Vote As Helpful" if it was useful! :)

    Wednesday, March 1, 2017 7:18 AM
  • Can someone please indicate from what table/view the usage.xlsx report is built from??

    Looking for data in the table/view will help me realize if data was collected or not and if the problem is only on the reporting side.

    If I have a problem only in generating the report, I don´t understand why should I use a login with dbowner role.

    Help is really appreciated.



    Monday, March 13, 2017 11:39 PM