Error in included netrndis.inf file following template RNDIS INF


  • Writing an INF file for an Ethernet over USB device and using the Remote NDIS INF template.

    The following section of the template indicates it must be included.

    include         = netrndis.inf
    needs           = Usb_Rndis.ndi

    When our device is installed (plug-n-play), Windows installs our INF, which includes netrndis.inf, which gives an error at line 99:
    ServiceBinary   = %12%\usb8023x.sys

    The file usb8023x.sys does not exist in System32/drivers folder. This results in error 0xe0000217, resulting in our device failing to install.

    Do we need to include netrndis.inf? How can we get it to run without failing?

    The INF needs to work on Win XP, 2003, Vista, 2008.

    Here is what our INF looks like:

    ; Our Company
    ; Based on Remote NDIS template device setup file for the RNDIS-over-USB host driver.
    Signature           = "$Windows NT$"
    Class               = Net
    ClassGUID           = {4d36e972-e325-11ce-bfc1-08002be10318}
    Provider            = %Company%
    DriverVer           = 08/10/2009,

    %Company%          = Company,NT.5.1, NTx86.6.0

    ; NetChip IDs, used by both firmware modes
    %UsbEnetDevice%  = RNDIS, USB\VID_1adb&PID_0003

    %UsbEnetDevice%  = RNDIS.NT.5.1, USB\VID_1adb&PID_0003

    %UsbEnetDevice%  = RNDIS.NT.5.1, USB\VID_1adb&PID_0003


    Characteristics = 0x84   ; NCF_PHYSICAL + NCF_HAS_UI
    BusType         = 15
    DriverVer       = 04/30/2009,
    AddReg          = RNDIS_AddReg_51, RNDIS_AddReg_Common

    include         = netrndis.inf
    needs           = Usb_Rndis.ndi.Services
    AddService      = USB_RNDIS, 2, RNDIS_ServiceInst_51, RNDIS_EventLog

    DisplayName     = %ServiceDisplayName%
    ServiceType     = 1
    StartType       = 3
    ErrorControl    = 1
    ServiceBinary   = %12%\usb8023.sys   
    LoadOrderGroup  = NDIS
    AddReg          = RNDIS_WMI_AddReg_51

    HKR, , MofImagePath, 0x00020000, "System32\drivers\rndismp.sys"

    HKR, Ndi,               Service,        0, "USB_RNDIS"
    HKR, Ndi\Interfaces,    UpperRange,     0, "ndis5"
    HKR, Ndi\Interfaces,    LowerRange,     0, "ethernet"

    AddReg = RNDIS_EventLog_AddReg

    HKR, , EventMessageFile, 0x00020000, "%%SystemRoot%%\System32\netevent.dll"
    HKR, , TypesSupported,   0x00010001, 7

    HKR, NDI\params\NetworkAddress, ParamDesc,  0, %NetworkAddress%
    HKR, NDI\params\NetworkAddress, type,       0, "edit"
    HKR, NDI\params\NetworkAddress, LimitText,  0, "12"
    HKR, NDI\params\NetworkAddress, UpperCase,  0, "1"
    HKR, NDI\params\NetworkAddress, default,    0, " "
    HKR, NDI\params\NetworkAddress, optional,   0, "1"



    DefaultDestDir = 12

    ServiceDisplayName    = "USB Remote NDIS Network Device Driver"
    NetworkAddress        = "Network Address"
    Company                = "Our Company"
    UsbEnetDevice      = "USB Ethernet/RNDIS Gadget"
    SourceDisk            = "Ethernet/RNDIS Gadget Driver Install Disk"

    If I comment out the line "include = netrndis.inf" it seems to work. Is it OK to not include netrndis.inf?



    Wednesday, August 12, 2009 5:46 PM

All replies

  • Fixed it. Had to move

    include         = netrndis.inf
    needs           = Usb_Rndis.ndi.Services

    to the [RNDIS.NT.5.1] section.
    • Proposed as answer by IT_Ezz Monday, October 22, 2012 5:52 PM
    Wednesday, August 12, 2009 11:39 PM
  • Fixed it. Had to move

    include         = netrndis.inf
    needs           = Usb_Rndis.ndi.Services

    to the [RNDIS.NT.5.1] section.

    Thanks man, i had a problem with usb modem huawei E303 which was working on win7 but not on win xp and had that exclamation in device manager with code 10 on device windows mobile-based internet sharing really were so helpful.

    • Edited by IT_Ezz Monday, October 22, 2012 6:00 PM
    Monday, October 22, 2012 5:58 PM