locked
Datetime filters - Day and month switching back and forth RRS feed

  • Question

  • Hi,

    Odd thing here and I didn't find anything about this issue yet. Everything is Ok for most users but one internally and a customer too. We have an SSRS report with few filters, 2 of them are StartDate and EndDate, both are Date/Time data type. They are set with default values as follow:

    StartDate = DATEADD("d",-7,TODAY())

    End Date =Today()

    Nothing unusual so far. When I call the report from the asp.net app, the filters are properly filled for everyone but that user, which in the filter textbox, the format that appears isn't the same as shown in the report (2014-01-15 00:00AM vs 1/15/2014). Now if it was only the issue, it wouldn't be a big deal, but the odd thing is when we click "View Report", the day and month values are switching, but they are switching every time.

    It means when I click View Report first, the date value filter is switching from 2014-01-15 00:00AM to 2014-15-01 (with no time anymore), then when I click View Report again without changing anything, the value return back to 2014-01-15. No need to say that it affects the filters and the shown values, which it shouldn't.

    We have this issue internally for 1 user only so far. I tried to change the Regional Settings without any success.

    Do you guys have an idea what is going on and if there's a way to enforce the datetime format used in the filter textbox?

    Thanks many times for you help and time!

    Ben.

    Tuesday, March 4, 2014 5:19 PM

Answers

  • We found that in IE11 > Internet Options > Languages > English(Canada) was causing the issue. By removing this language preference et letting this option empty or using English(US), it worked now.

    Thanks

    • Marked as answer by Alisa Tang Wednesday, March 5, 2014 8:03 AM
    Tuesday, March 4, 2014 7:55 PM

All replies

  • We found that in IE11 > Internet Options > Languages > English(Canada) was causing the issue. By removing this language preference et letting this option empty or using English(US), it worked now.

    Thanks

    • Marked as answer by Alisa Tang Wednesday, March 5, 2014 8:03 AM
    Tuesday, March 4, 2014 7:55 PM
  • Hi Ben,

    Glad to heard that the issue had been solved and thanks for your sharing. It will be very beneficial for other community members who have similar questions.

    I’d like to mark this issue as "Answered". Please also feel free to unmark the issue, with any new findings or concerns you may have.

    Regards,
    Alisa Tang


    Alisa Tang
    TechNet Community Support

    Wednesday, March 5, 2014 8:03 AM