cannot run apps deployed by VS2013 RRS feed

  • Question

  • My add store and other apps can be run normally.

    However when I use VS2013 to deploy an Windows SDK sample, I face the following situations.

    1) Start without debugging: an app container is opened, as a single-color screen(light blue in my case), the white text "Windows SDK" is shown in the middle of screen. And that's it. no further reaction in the following few minutes. If I close the container, VS2013 prompts a error message "Unable to activate Windows Store App 'appname'. The activation request failed with error 'The app didn't start int he required time'." and I saw an event in the event log: Activation of the app Microsoft.SDKSamples.D2DPixelShaderEffect.CPP_8wekyb3d8bbwe!DirectXApplication.App for the Windows.Launch contract timed out.

    2) Start debugging: the same as 1) except that the error message is not prompted if I close the container. VS2013 is still in the debugging mode. It cannot execute "break all" because "no processes are being debugged"

    3) deploy the app and start from modern start window, like other apps: same as 1). In addition, The event is not the same, though:

    The description for Event ID 2095 from source Microsoft-Windows-Immersive-Shell cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event: 
    The message id for the desired message could not be found

    I've tried many solutions on Google:

    1) WSRESET.exe --> like...nothing happened

    2) sfc /scannow --> no integrity violation found

    3) powershell Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.XML --> successful, but not working

    4)apps troubleshooter --> only shows some possible issues: like configuration is demaged, cache is damaged. (Oh, and not the same conditions for every time I ran the troubleshooter)

    Actually Im not so suprised that the solutions are not effective because the solutions are targeted on general failure: all apps, incluing stores itself, cannot be run. My case is that only apps deployed by VS2013 (or maybe any apps not downloaded from store) cannot be activated normally.

    Can anyone helps, please? I really don't refresh/recover my PCs. It take a lot of effort to re-install dozens of applications.

    Tuesday, November 17, 2015 2:20 AM


  • Hi Linmuadido,

    Does this problem just occur with this specific Windows Store App?

    Please create a new Windows Store App with Visual Studio 2013 to check whether this problem occurs which all Windows Store Apps.

    If for all apps, please try with following steps to troubleshoot this problem.

    1. Install the Update 5 for VS2013, which is the latest version of update currently.
    2. Install the latest version of Windows SDK for your Windows version.
    3. Run VS2013 as Adminstrator.
    4. Run Visual Studio in safe mode with "Deven.exe /SafeMode" to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    5. Repair VS2013 through Control Panel -> VS2013 -> Change -> Repair.

    If for a specific Windows Store App, please create a new specific Windows Store App with VS2013 and then remove the project file from the failed app to the new one.

    If possible, please provide a sample project to OneDrive and share the link here, which can help us produce your problem.

    Best Regards,

    • Proposed as answer by Weiwei Cai Friday, November 20, 2015 9:56 AM
    • Marked as answer by linmuadido Monday, November 23, 2015 4:05 AM
    Wednesday, November 18, 2015 3:29 AM